diff mbox series

[bug#42080,4/4] gnu: Add r-rselenium.

Message ID 20200627114823.10738-4-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42080,1/4] gnu: Add r-semver. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 27, 2020, 11:48 a.m. UTC
* gnu/packages/cran.scm (r-rselenium): New variable.
---
 gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e2eb06b5db..48a619956e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22418,3 +22418,39 @@  repositories to be added.")
 for more information).  This package provides functions to download
 these binaries and to manage processes involving them.")
     (license license:expat)))
+
+(define-public r-rselenium
+  (package
+    (name "r-rselenium")
+    (version "1.7.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "RSelenium" version))
+        (sha256
+          (base32
+            "1xn5fdbzmq7b1f5fc9ls23g177bmnd8bn4p4d8aafr6z3jwkmfir"))))
+    (properties `((upstream-name . "RSelenium")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-binman" ,r-binman)
+        ("r-catools" ,r-catools)
+        ("r-httr" ,r-httr)
+        ("r-openssl" ,r-openssl)
+        ("r-wdman" ,r-wdman)
+        ("r-xml" ,r-xml)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "http://docs.ropensci.org/RSelenium")
+    (synopsis "R Bindings for 'Selenium WebDriver'")
+    (description
+      "This package provides a set of R bindings for the 'Selenium 2.0
+WebDriver' (see <https://selenium.dev/documentation/en/> for more
+information) using the 'JsonWireProtocol' (see
+<https://github.com/SeleniumHQ/selenium/wiki/JsonWireProtocol> for
+more information). 'Selenium 2.0 WebDriver' allows driving a web
+browser natively as a user would either locally or on a remote machine
+using the Selenium server it marks a leap forward in terms of web
+browser automation.  Selenium automates web browsers (commonly
+referred to as browsers).  Using RSelenium you can automate browsers
+locally or remotely.")
+    (license license:agpl3+)))