diff mbox series

[bug#42079] gnu: Add r-rismed.

Message ID 20200627110743.6814-1-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42079] gnu: Add r-rismed. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 27, 2020, 11:07 a.m. UTC
* gnu/packages/cran.scm (r-rismed): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès July 13, 2020, 10:41 a.m. UTC | #1
Hi Peter,

Peter Lo <peterloleungyau@gmail.com> skribis:

> * gnu/packages/cran.scm (r-rismed): New variable.

Applied, thanks!  I added you as a copyright holder in that file; let me
know if I got it wrong.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..afd5c0e1e3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,27 @@  across a wide array of bioinformatic R packages.")
 and clustering large sequence datasets using fast alignment-free k-mer
 counting and recursive k-means partitioning.")
     (license license:gpl3)))
+
+(define-public r-rismed
+  (package
+    (name "r-rismed")
+    (version "2.1.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "RISmed" version))
+        (sha256
+          (base32
+            "08dmkkxsmwp9b4h2g1bbx03cijn793fsnzkmbima8x9d42vxnm1l"))))
+    (properties `((upstream-name . "RISmed")))
+    (build-system r-build-system)
+    (home-page
+      "https://cran.r-project.org/web/packages/RISmed")
+    (synopsis "Download Content from NCBI Databases")
+    (description
+      "This package provides a set of tools to extract bibliographic
+content from the National Center for Biotechnology Information (NCBI)
+databases, including PubMed.  The name RISmed is a portmanteau of
+RIS (for Research Information Systems, a common tag format for
+bibliographic data) and PubMed.")
+    (license license:gpl2+)))