diff mbox series

[bug#42040] gnu: mumble: Fix mumble-overlay.

Message ID 20200625134618.13491-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#42040] gnu: mumble: Fix mumble-overlay. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler June 25, 2020, 1:46 p.m. UTC
The canonical mumble-overlay script searches for libmumble.so.1 in various
directories, none of which are relevant in Guix installations and
additionally does some work to match the architecture of the library to that
of the command that will be executed.
This work is unnecessary in Guix and only causes the script to fail, so we
instead just hardcode the path.

* gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay.
---
 gnu/packages/telephony.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Ludovic Courtès June 28, 2020, 9:16 p.m. UTC | #1
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

> The canonical mumble-overlay script searches for libmumble.so.1 in various
> directories, none of which are relevant in Guix installations and
> additionally does some work to match the architecture of the library to that
> of the command that will be executed.
> This work is unnecessary in Guix and only causes the script to fail, so we
> instead just hardcode the path.
>
> * gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay.

Applied, thanks!

The original ‘script/mumble-overlay’ script is surprisingly complex.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4c84ddc85a..542d36a841 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -588,6 +588,16 @@  address of one of the participants.")
              (substitute* "src/mumble/Settings.cpp"
                (("bUsage = true;") "bUsage = false;"))
              #t))
+         (add-before 'configure 'fix-mumble-overlay
+           (lambda* (#:key outputs #:allow-other-keys)
+              (with-output-to-file "scripts/mumble-overlay"
+                (lambda ()
+                  (format #t "#!~a~%" (which "bash"))
+                  (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
+                          (string-append (assoc-ref outputs "out")
+                                         "/lib/mumble/libmumble.so.1"))
+                  (format #t "exec \"${@}\"")))
+              #t))
          (add-before 'install 'disable-murmur-ice
            (lambda _
              (substitute* "scripts/murmur.ini.system"