diff mbox series

[bug#42015] gnu: Add python-imageio.

Message ID 20200623030736.21717-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42015] gnu: Add python-imageio. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego June 23, 2020, 3:07 a.m. UTC
* gnu/packages/python-science.scm (python-imageio): New variable.
---
 gnu/packages/python-science.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Marius Bakke June 24, 2020, 7:18 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/python-science.scm (python-imageio): New variable.

It looks like Ricardo committed a variant of this patch in
88e0101b61af45584d36af541c499258d037f2ac.  However I think I prefer your
description, and the home page seems more appropriate.  Would you like
to submit an update for those?  :-)
Vinicius Monego June 26, 2020, 8:34 p.m. UTC | #2
Hello,

> It looks like Ricardo committed a variant of this patch in
> 88e0101b61af45584d36af541c499258d037f2ac.  However I think I prefer
> your
> description, and the home page seems more appropriate.  Would you
> like
> to submit an update for those?  :-)

Sure. You didn't mention synopsis, so I sent two patches: one with and
another without a synopsis change. You can choose either.
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 2f7516b9f6..ab09189e41 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -195,6 +196,29 @@  depends on @code{scipy.weave}.  For new code, users are recommended to use
 Cython.")
     (license license:bsd-3)))
 
+(define-public python-imageio
+  (package
+    (name "python-imageio")
+    (version "2.8.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "imageio" version))
+        (sha256
+          (base32 "1ksjl523fm0fikrd85llxfba35rc1qsgwadgr6mbn9kis79xcpzv"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:tests? #f)) ; tests require downloading images from remote servers
+    (propagated-inputs
+      `(("python-numpy" ,python-numpy)
+        ("python-pillow" ,python-pillow)))
+    (home-page "https://imageio.github.io/")
+    (synopsis "Library for reading and writing a wide range of image data")
+    (description "Imageio is a Python library that provides an easy interface
+to read and write a wide range of image data, including animated images, video,
+volumetric data, and scientific formats.")
+    (license license:bsd-2)))
+
 (define-public python-scikit-image
   (package
     (name "python-scikit-image")