diff mbox series

[bug#41991,2/2] gnu: Add webvfx.

Message ID 20200621182547.27225-2-monego@posteo.net
State Accepted
Headers show
Series [bug#41990,1/2] gnu: mlt: Update to 6.20.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 21, 2020, 6:25 p.m. UTC
* gnu/packages/video.scm (webvfx): New variable.
---
 gnu/packages/video.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Marius Bakke June 22, 2020, 9:36 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/video.scm (webvfx): New variable.

This fails to install like so:

make[2]: Entering directory '/tmp/guix-build-webvfx-1.2.0.drv-0/source/mlt'
/gnu/store/59dq1n4wj3maa3kcar6hspj2zd82as7q-qtbase-5.14.2/bin/qmake -install qinstall -exe ../build/release/libmltwebvfx.so /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so
Error copying ../build/release/libmltwebvfx.so to /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so: Cannot create /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so for output

It seems it attempts to write the the mlt store directory.  Can you look
into it?

TIA,
Marius
Ludovic Courtès Sept. 2, 2020, 3:10 p.m. UTC | #2
Hi Vinicius,

Friendly ping!  :-)

Marius Bakke <marius@gnu.org> skribis:

> Vinicius Monego <monego@posteo.net> writes:
>
>> * gnu/packages/video.scm (webvfx): New variable.
>
> This fails to install like so:
>
> make[2]: Entering directory '/tmp/guix-build-webvfx-1.2.0.drv-0/source/mlt'
> /gnu/store/59dq1n4wj3maa3kcar6hspj2zd82as7q-qtbase-5.14.2/bin/qmake -install qinstall -exe ../build/release/libmltwebvfx.so /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so
> Error copying ../build/release/libmltwebvfx.so to /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so: Cannot create /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so for output
>
> It seems it attempts to write the the mlt store directory.  Can you look
> into it?
>
> TIA,
> Marius
Vinicius Monego Sept. 2, 2020, 4:59 p.m. UTC | #3
Ludovic Courtès writes:

> Hi Vinicius,
>
> Friendly ping!  :-)
>

Hello Ludo, Marius.

Apologies for the delay. An easy solution to this is to disable 
the MLT
services by removing MLT from the inputs. I intended to have them
enabled because I was packaging webvfx as optional dependency for 
the
Shotcut video editor, which uses MLT.

However, I checked the webvfx repository right now and it was 
deprecated
in the meantime and is no longer maintained. For this reason I am
closing the issue.

Vinicius
Ludovic Courtès Sept. 2, 2020, 8:19 p.m. UTC | #4
Hi,

Vinicius Monego <monego@posteo.net> skribis:

> Apologies for the delay. An easy solution to this is to disable the
> MLT
> services by removing MLT from the inputs. I intended to have them
> enabled because I was packaging webvfx as optional dependency for the
> Shotcut video editor, which uses MLT.
>
> However, I checked the webvfx repository right now and it was
> deprecated
> in the meantime and is no longer maintained. For this reason I am
> closing the issue.

OK, thank you for the quick reply!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e51729138c..a0b454c403 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2390,6 +2390,44 @@  functionality of the system is provided via an assortment of ready to use
 tools, XML authoring components, and an extensible plug-in based API.")
     (license license:gpl3)))
 
+(define-public webvfx
+  (package
+    (name "webvfx")
+    (version "1.2.0")
+    (source
+     (origin
+      (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mltframework/webvfx")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0brpnf2yllx3510dlm1p7bq5p5havnvr1bglhsbl2f07281m7nl1"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (let ((out (assoc-ref %outputs "out")))
+               (invoke "qmake"
+                       (string-append "PREFIX=" out)
+                       "all.pro")))))))
+    (native-inputs
+     `(("qmake" ,qttools)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtwebkit" ,qtwebkit)))
+    (propagated-inputs
+     `(("mlt" ,mlt)))
+    (home-page "https://github.com/mltframework/webvfx")
+    (synopsis "Video effects engine based on web technologies")
+    (description "WebVfx is a video effects library that allows effects to
+be implemented using WebKit HTML or Qt QML.")
+    (license license:bsd-3)))
+
 (define-public v4l-utils
   (package
     (name "v4l-utils")