diff mbox series

[bug#41978] gnu: add convmv.

Message ID 20200621121755.17707-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#41978] gnu: add convmv. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler June 21, 2020, 12:17 p.m. UTC
* gnu/packages/convmv.scm: New file.
* gnu/local.mk: Add it to build.
---
 gnu/local.mk            |  1 +
 gnu/packages/convmv.scm | 61 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 62 insertions(+)
 create mode 100644 gnu/packages/convmv.scm

Comments

Julien Lepiller June 21, 2020, 1:54 p.m. UTC | #1
Pushed as bdafdfcec9861f53f93fc9cf81c2e83fe45c35dd with a change to
make closing parenthesis less lonely :)

Thank you!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index fd3cc88af5..ee1bcab2a0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -134,6 +134,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/compton.scm 			\
   %D%/packages/conky.scm			\
   %D%/packages/connman.scm			\
+  %D%/packages/convmv.scm			\
   %D%/packages/cook.scm				\
   %D%/packages/coq.scm				\
   %D%/packages/cpio.scm				\
diff --git a/gnu/packages/convmv.scm b/gnu/packages/convmv.scm
new file mode 100644
index 0000000000..825d73833c
--- /dev/null
+++ b/gnu/packages/convmv.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages convmv)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages perl)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public convmv
+  (package
+    (name "convmv")
+    (version "2.05")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.j3e.de/linux/convmv/convmv-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:test-target "test"
+       #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'bootstrap)
+         (delete 'configure)
+         (add-before 'check 'unpack-testsuite
+           (lambda _
+             (invoke "tar" "xf" "testsuite.tar")
+             (patch-shebang "suite/dotests.sh")
+             (patch-shebang "suite/parsable_tester.pl")
+             #t))
+         )))
+    (inputs
+     `(("perl" ,perl)))
+    (synopsis "Convert filenames between character sets")
+    (description
+     "convmv is a file renamer, that converts between different encodings,
+e.g. from ISO-8859-1 to UTF-8.  It is particularly usefuls for files with
+names, that display incorrectly.")
+    (license (list gpl2 gpl3))
+    (home-page "https://www.j3e.de/")))