diff mbox series

[bug#41964,2/2] gnu: Add 'pass-tomb'.

Message ID 20200620151111.28385-2-brice@waegenei.re
State Accepted
Headers show
Series Add pass-tomb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire June 20, 2020, 3:11 p.m. UTC
* gnu/packages/password-utils.scm (pass-tomb): New variable.
---
 gnu/packages/password-utils.scm | 41 +++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Danny Milosavljevic July 17, 2020, 6:52 p.m. UTC | #1
On Sat, 20 Jun 2020 17:11:11 +0200
Brice Waegeneire <brice@waegenei.re> wrote:

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'set-tomb-path
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (let ((tomb (assoc-ref inputs "tomb")))
> +               (substitute* "tomb.bash"
> +                 ((":-tomb")
> +                  (string-append ":-" tomb "/bin/tomb"))))))

Phase should end in #t.
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 6bd1e94c91..c356dba309 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1210,3 +1210,44 @@  desired length.  It can also generate their corresponding hashes for a given
 encryption algorithm if so desired.")
       (home-page "https://github.com/khorben/makepasswd")
       (license license:gpl3))))
+
+(define-public pass-tomb
+  (package
+    (name "pass-tomb")
+    (version "1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/roddhjav/pass-tomb")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qj7vx7svk1ljwihj3kv310k17mafnf919n30n4qn1yxmmsvj924"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list (string-append "PREFIX=" out)
+               (string-append "BASHCOMPDIR=" out "/etc/bash_completion.d")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'set-tomb-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((tomb (assoc-ref inputs "tomb")))
+               (substitute* "tomb.bash"
+                 ((":-tomb")
+                  (string-append ":-" tomb "/bin/tomb"))))))
+         (delete 'configure)
+         ;; No test suite
+         (delete 'check))))
+    (inputs
+     `(("tomb" ,tomb)))
+    (home-page "https://github.com/roddhjav/pass-tomb")
+    (synopsis "Pass extension keeping the tree of passwords encrypted")
+    (description "Pass-tomb provides a convenient solution to put your
+password store in a Tomb and then keep your password tree encrypted when you
+are not using it.  It uses the same GPG key to encrypt passwords and tomb,
+therefore you don't need to manage more key or secret.  Moreover, you can ask
+pass-tomb to automatically close your store after a given time.")
+    (license license:gpl3+)))