diff mbox series

[bug#41954] gnu: Add gmic.

Message ID 20200619202625.35415-1-monego@posteo.net
State Accepted
Headers show
Series [bug#41954] gnu: Add gmic. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 19, 2020, 8:26 p.m. UTC
* gnu/packages/image-processing.scm (gmic): New variable.
---
 gnu/packages/image-processing.scm | 39 +++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Marius Bakke June 22, 2020, 9:13 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/image-processing.scm (gmic): New variable.

[...]
  
> +(define-public gmic
> +  (package
> +    (name "gmic")
> +    (version "2.9.1")
> +    (source
> +     (origin
> +      (method url-fetch)
> +      (uri (string-append
> +            "https://gmic.eu/files/source/gmic_"
> +            version ".tar.gz"))
> +      (sha256
> +       (base32 "13axx7nwchn6ysgpvlw3fib474q4nrwv3qn20g3q03ldid0xvjah"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f))

Can you add a comment about why tests are disabled?

> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("curl" ,curl)
> +       ("fftw" ,fftw)
> +       ("graphicsmagick" ,graphicsmagick)
> +       ("libjpeg-turbo" ,libjpeg-turbo)
> +       ("libpng" ,libpng)
> +       ("libtiff" ,libtiff)
> +       ("libx11" ,libx11)
> +       ;;("opencv" ,opencv) ; OpenCV is currently broken in the CI

:-(

> +       ("openexr" ,openexr)
> +       ("zlib" ,zlib)))
> +    (home-page "https://gmic.eu/")
> +    (synopsis "Full-featured framework for digital image processing")
> +    (description "G'MIC is a full-featured framework for digital image
> +processing.  It provides several user interfaces to convert / manipulate
> +/ filter / visualize generic image datasets, ranging from 1D scalar
> +signals to 3D+t sequences of multi-spectral volumetric images, hence
> +including 2D color images.")
> +    (license (list license:cecill ;; G'MIC is dual-licensed.
> +                   license:cecill-c))))

Can you expand on the license comment a bit?  Can the user choose which
license, or do both apply somehow?

Otherwise LGTM, thanks!
Vinicius Monego June 22, 2020, 10:01 p.m. UTC | #2
Em seg, 2020-06-22 às 23:13 +0200, Marius Bakke escreveu:
> Vinicius Monego <monego@posteo.net> writes:
> 
> > * gnu/packages/image-processing.scm (gmic): New variable.
> 
> [...]
>   
> > +(define-public gmic
> > +  (package
> > +    (name "gmic")
> > +    (version "2.9.1")
> > +    (source
> > +     (origin
> > +      (method url-fetch)
> > +      (uri (string-append
> > +            "https://gmic.eu/files/source/gmic_"
> > +            version ".tar.gz"))
> > +      (sha256
> > +       (base32
> > "13axx7nwchn6ysgpvlw3fib474q4nrwv3qn20g3q03ldid0xvjah"))))
> > +    (build-system cmake-build-system)
> > +    (arguments
> > +     `(#:tests? #f))
> 
> Can you add a comment about why tests are disabled?

Yes, there are no tests.

> > +    (native-inputs
> > +     `(("pkg-config" ,pkg-config)))
> > +    (inputs
> > +     `(("curl" ,curl)
> > +       ("fftw" ,fftw)
> > +       ("graphicsmagick" ,graphicsmagick)
> > +       ("libjpeg-turbo" ,libjpeg-turbo)
> > +       ("libpng" ,libpng)
> > +       ("libtiff" ,libtiff)
> > +       ("libx11" ,libx11)
> > +       ;;("opencv" ,opencv) ; OpenCV is currently broken in the CI
> 
> :-(
> 
> > +       ("openexr" ,openexr)
> > +       ("zlib" ,zlib)))
> > +    (home-page "https://gmic.eu/")
> > +    (synopsis "Full-featured framework for digital image
> > processing")
> > +    (description "G'MIC is a full-featured framework for digital
> > image
> > +processing.  It provides several user interfaces to convert /
> > manipulate
> > +/ filter / visualize generic image datasets, ranging from 1D
> > scalar
> > +signals to 3D+t sequences of multi-spectral volumetric images,
> > hence
> > +including 2D color images.")
> > +    (license (list license:cecill ;; G'MIC is dual-licensed.
> > +                   license:cecill-c))))
> 
> Can you expand on the license comment a bit?  Can the user choose
> which
> license, or do both apply somehow?

This is an excerpt from the copyright header in one of the files:

 #  This software is governed either by the CeCILL or the CeCILL-C
license
 #  under French law and abiding by the rules of distribution of free
software.

From my limited understanding, the user can choose either.

I will send a v2 with the proposed changes.

> Otherwise LGTM, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 801dc70149..efafcbacf0 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Lprndn <guix@lprndn.info>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -487,6 +488,44 @@  quickly, especially on machines with more than one CPU core.  This is primarily
 due to its architecture which automatically parallelises the image workflows.")
     (license license:lgpl2.1+)))
 
+(define-public gmic
+  (package
+    (name "gmic")
+    (version "2.9.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "https://gmic.eu/files/source/gmic_"
+            version ".tar.gz"))
+      (sha256
+       (base32 "13axx7nwchn6ysgpvlw3fib474q4nrwv3qn20g3q03ldid0xvjah"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("curl" ,curl)
+       ("fftw" ,fftw)
+       ("graphicsmagick" ,graphicsmagick)
+       ("libjpeg-turbo" ,libjpeg-turbo)
+       ("libpng" ,libpng)
+       ("libtiff" ,libtiff)
+       ("libx11" ,libx11)
+       ;;("opencv" ,opencv) ; OpenCV is currently broken in the CI
+       ("openexr" ,openexr)
+       ("zlib" ,zlib)))
+    (home-page "https://gmic.eu/")
+    (synopsis "Full-featured framework for digital image processing")
+    (description "G'MIC is a full-featured framework for digital image
+processing.  It provides several user interfaces to convert / manipulate
+/ filter / visualize generic image datasets, ranging from 1D scalar
+signals to 3D+t sequences of multi-spectral volumetric images, hence
+including 2D color images.")
+    (license (list license:cecill ;; G'MIC is dual-licensed.
+                   license:cecill-c))))
+
 (define-public nip2
   (package
     (name "nip2")