diff mbox series

[bug#41916] gnu: xsnow: Update to 2.0.22.

Message ID 20200617115432.23438-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#41916] gnu: xsnow: Update to 2.0.22. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Timotej Lazar June 17, 2020, 11:54 a.m. UTC
* gnu/packages/toys.scm (xsnow): Update to 2.0.22.
---
 gnu/packages/toys.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Efraim Flashner June 17, 2020, 1:26 p.m. UTC | #1
This builds successfully but I can't get it to launch on my computer.
Does it work for you?

(xsnow:2443): dbind-WARNING **: 16:26:23.769: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
Detected desktop session: /run/current-system/profile/share/xsessions/enlightenment
Your screen supports alpha channel, good.
xsnow: cannot determine window, exiting...
Efraim Flashner June 17, 2020, 1:33 p.m. UTC | #2
On Wed, Jun 17, 2020 at 04:26:53PM +0300, Efraim Flashner wrote:
> This builds successfully but I can't get it to launch on my computer.
> Does it work for you?
> 
> (xsnow:2443): dbind-WARNING **: 16:26:23.769: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
> Detected desktop session: /run/current-system/profile/share/xsessions/enlightenment
> Your screen supports alpha channel, good.
> xsnow: cannot determine window, exiting...

Actually this is the same message I get with the version currently
packaged. I assume the updated one works just as well as before, as long
as it's not on my computer.

Patch pushed.
Timotej Lazar June 17, 2020, 1:37 p.m. UTC | #3
Efraim Flashner <efraim@flashner.co.il> [2020-06-17 16:26:53+0300]:
> This builds successfully but I can't get it to launch on my computer.
> Does it work for you?

It does, but I have only tested with i3. Does the version currently in
Guix (2.0.15) work for you?
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 7f22646d8c..f643e06974 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
-;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -167,7 +167,7 @@  The GNU project hosts a similar collection of filters, the GNU talkfilters.")
 (define-public xsnow
   (package
     (name "xsnow")
-    (version "2.0.15")
+    (version "2.0.22")
     (source
      (origin
        (method url-fetch)
@@ -175,7 +175,7 @@  The GNU project hosts a similar collection of filters, the GNU talkfilters.")
              "https://www.ratrabbit.nl/ratrabbit/system/files/xsnow/xsnow-"
              version ".tar.gz"))
        (sha256
-        (base32 "086s42frbz9bk550414v908yrax4iwwlvlxv4zwp39cyp7wgws03"))))
+        (base32 "1880643fal6l7bskqbm4zfbr2s719698mkx4pchrxkjpb240sj0z"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases