diff mbox series

[bug#41880] gnu: go-ipfs: Update to 0.5.1.

Message ID 20200615201140.24235-1-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#41880] gnu: go-ipfs: Update to 0.5.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Martin Becze June 15, 2020, 8:11 p.m. UTC
* gnu/packages/ipfs.scm (go-ipfs): Update to 0.5.1
---
 gnu/packages/ipfs.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Michael Rohleder June 15, 2020, 11:07 p.m. UTC | #1
Martin Becze <mjbecze@riseup.net> writes:
> * gnu/packages/ipfs.scm (go-ipfs): Update to 0.5.1

afaik, this version doesn't support http POST anymore.
Maybe this could break things in the ipfs branches?
Martin Becze June 16, 2020, 12:53 a.m. UTC | #2
Whats in the ipfs branch? I'm down to test, if I know what to test.

On 6/15/20 6:07 PM, Michael Rohleder wrote:
> Martin Becze <mjbecze@riseup.net> writes:
>> * gnu/packages/ipfs.scm (go-ipfs): Update to 0.5.1
> 
> afaik, this version doesn't support http POST anymore.
> Maybe this could break things in the ipfs branches?
>
Ludovic Courtès June 18, 2020, 12:46 p.m. UTC | #3
Hi Martin,

Martin Becze <mjbecze@riseup.net> skribis:

> * gnu/packages/ipfs.scm (go-ipfs): Update to 0.5.1

Applied!

Michael Rohleder <mike@rohleder.de> skribis:

> afaik, this version doesn't support http POST anymore.
> Maybe this could break things in the ipfs branches?

Good to know.  We’ll have to adjust the code there; that shouldn’t
prevent us from updating the package in the meantime IMO.

Martin Becze <mjbecze@riseup.net> skribis:

> Whats in the ipfs branch? I'm down to test, if I know what to test.

It’s at <https://issues.guix.gnu.org/33899>, but don’t worry about it.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 7ef7108c1f..15f174f8b6 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -212,7 +213,7 @@  written in Go.")
 (define-public go-ipfs
   (package
     (name "go-ipfs")
-    (version "0.4.23")
+    (version "0.5.1")
     (source
      (origin
        (method url-fetch/tarbomb)
@@ -220,7 +221,7 @@  written in Go.")
              "https://dist.ipfs.io/go-ipfs/v" version
              "/go-ipfs-source.tar.gz"))
        (sha256
-        (base32 "191ir4h6c76xcnbwx9fj8j2lzzqyp10inmqd8sa393b5y0jmhi5a"))
+        (base32 "0lpilycjbc1g9adp4d5kryfprixj18hg3235fnivakmv7fy2akkm"))
        (file-name (string-append name "-" version "-source"))))
     (build-system go-build-system)
     (arguments