diff mbox series

[bug#41869] gnu: libmateweather: Add patch to rename a timezone city.

Message ID 20200615101001.30670-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series [bug#41869] gnu: libmateweather: Add patch to rename a timezone city. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jonathan Brielmaier June 15, 2020, 10:10 a.m. UTC
This let the check phase succeed again.

* gnu/packages/mate.scm (libmateweather)[source]: Add patch.
* gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Register it.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/mate.scm                         |  4 ++-
 ...ibmateweather-rename-godthab-to-nuuk.patch | 34 +++++++++++++++++++
 3 files changed, 38 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch

--
2.26.2

Comments

Efraim Flashner June 15, 2020, 10:29 a.m. UTC | #1
This looks like it could just be a snippet in the origin
Jonathan Brielmaier June 15, 2020, 10:38 a.m. UTC | #2
Could be, but I'm more a fan of patches because it will fail after the
next update of the package. Snippets are easier to forget for clean up...

On 15.06.20 12:29, Efraim Flashner wrote:
> This looks like it could just be a snippet in the origin
Jonathan Brielmaier June 16, 2020, 11:53 p.m. UTC | #3
Closing. Mathieu did it in e23ec7144c264902ac13fa75e01a206e4d907e5a

On 15.06.20 12:38, Jonathan Brielmaier wrote:
> Could be, but I'm more a fan of patches because it will fail after the
> next update of the package. Snippets are easier to forget for clean up...
>
> On 15.06.20 12:29, Efraim Flashner wrote:
>> This looks like it could just be a snippet in the origin
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 7333427850..c6293e4b1c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1186,6 +1186,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/libmad-length-check.patch		\
   %D%/packages/patches/libmad-md_size.patch			\
   %D%/packages/patches/libmad-mips-newgcc.patch			\
+  %D%/packages/patches/libmateweather-rename-godthab-to-nuuk.patch		\
   %D%/packages/patches/libmp4v2-c++11.patch			\
   %D%/packages/patches/libmpeg2-arm-private-symbols.patch	\
   %D%/packages/patches/libmpeg2-global-symbol-test.patch	\
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8b548b5d8e..9b5d49b164 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -264,7 +264,9 @@  desktop and the mate-about program.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))))
+         "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))
+       (patches
+        (search-patches "libmateweather-rename-godthab-to-nuuk.patch"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
diff --git a/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch b/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch
new file mode 100644
index 0000000000..2cbe32d7b5
--- /dev/null
+++ b/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch
@@ -0,0 +1,34 @@ 
+https://github.com/mate-desktop/libmateweather/pull/77
+Makes check phase green again.
+
+From ea13e06563fb5fa53f8a9643156a64825e986acb Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Fri, 22 May 2020 20:19:57 +0200
+Subject: [PATCH] Locations: America/Godthab was renamed to America/Nuuk
+
+---
+ data/Locations.xml.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/Locations.xml.in b/data/Locations.xml.in
+index 5488867..62529b9 100644
+--- a/data/Locations.xml.in
++++ b/data/Locations.xml.in
+@@ -6482,7 +6482,7 @@
+             -->
+           <name>Danmarkshavn</name>
+         </timezone>
+-        <timezone id="America/Godthab">
++        <timezone id="America/Nuuk">
+           <!-- The primary timezone for Greenland, although sources
+                seem to point towards calling the area "Western
+                Greenland" rathern than just "Greenland".
+@@ -6502,7 +6502,7 @@
+           <name>Thule AFB</name>
+         </timezone>
+       </timezones>
+-      <tz-hint>America/Godthab</tz-hint>
++      <tz-hint>America/Nuuk</tz-hint>
+       <city>
+         <!-- A city in Greenland.
+              The local name in Kalaallisut is "Uummannaq".