diff mbox series

[bug#41854] gnu: musl: Enable gcc wrapper.

Message ID 20200614145308.32592-1-dannym@scratchpost.org
State New
Headers show
Series [bug#41854] gnu: musl: Enable gcc wrapper. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic June 14, 2020, 2:53 p.m. UTC
* gnu/packages/musl.scm (musl)[arguments]<#:configure-flags>: Delete.
---
 gnu/packages/musl.scm | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Mathieu Othacehe June 21, 2020, 9:47 a.m. UTC | #1
Hey Danny,

> -     `(#:tests? #f                      ; musl has no tests
> -       #:configure-flags
> -       (list "--disable-gcc-wrapper")))
> +     `(#:tests? #f))                    ; musl has no tests

Not sure why it was disabled in the first place, but I think you can go
for it.

Thanks,

Mathieu
Vincent Legoll March 12, 2021, 10:01 a.m. UTC | #2
Hello,

I don't remember why it was disabled, so
if it works for you, please go ahead and
commit.
diff mbox series

Patch

diff --git a/gnu/packages/musl.scm b/gnu/packages/musl.scm
index 44c39750d6..61519a36e0 100644
--- a/gnu/packages/musl.scm
+++ b/gnu/packages/musl.scm
@@ -38,9 +38,7 @@ 
                 "1s6lix02k1ijm4nmhzpmwzk5w6xfkhn70nvvk8zjs51r24cpppn6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; musl has no tests
-       #:configure-flags
-       (list "--disable-gcc-wrapper")))
+     `(#:tests? #f))                    ; musl has no tests
     (synopsis "Small C standard library")
     (description "musl is a simple and lightweight C standard library.  It
 strives to be correct in the sense of standards-conformance and safety.")