diff mbox series

[bug#41813] gnu: Add bbswitch-module.

Message ID 20200611202423.9284-1-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#41813] gnu: Add bbswitch-module. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Neidhardt June 11, 2020, 8:24 p.m. UTC
* gnu/packages/linux.scm (bbswitch-module): New variable.
---
 gnu/packages/linux.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Mathieu Othacehe June 14, 2020, 10:05 a.m. UTC | #1
Hello Pierre,

> +    (synopsis "Kernel module that disables discrete Nvidia graphics cards")
> +    (description "The bbswitch module provides a way to toggle the Nvidia
> +graphics card on Optimus laptops.")

The home page says that's it's intended to disable discrete graphics,
but only working with Nvidia currently. Maybe you should add this
information?

Otherwise, this looks good to me.

Thanks,

Mathieu
Pierre Neidhardt June 14, 2020, 10:27 a.m. UTC | #2
Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello Pierre,
>
>> +    (synopsis "Kernel module that disables discrete Nvidia graphics cards")
>> +    (description "The bbswitch module provides a way to toggle the Nvidia
>> +graphics card on Optimus laptops.")
>
> The home page says that's it's intended to disable discrete graphics,
> but only working with Nvidia currently. Maybe you should add this
> information?

Sorry, I'm not sure what you mean :)  Are you saying that I should
mention that it could potentially work with any brand in the future?
Considering the age of the last commit, I doubt it ever will :)
Mathieu Othacehe June 14, 2020, 10:42 a.m. UTC | #3
> Sorry, I'm not sure what you mean :)  Are you saying that I should
> mention that it could potentially work with any brand in the future?
> Considering the age of the last commit, I doubt it ever will :)

Yes, mmh, '2013' then I guess you're right.

Mathieu
Pierre Neidhardt June 14, 2020, 11:26 a.m. UTC | #4
Thanks, merged.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 73d99be48c..7c19517432 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1137,6 +1137,29 @@  network adapters.")
 between the CDemu userspace daemon and linux kernel.")
     (license license:gpl2+)))
 
+(define-public bbswitch-module
+  (package
+    (name "bbswitch-module")
+    (version "0.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Bumblebee-Project/bbswitch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1glch4j0x1dzlp2yrb67v2r5jg9609jb6p8m251y78m74advqw0l"))))
+    (build-system linux-module-build-system)
+    (arguments
+     ;; No tests.
+     `(#:tests? #f))
+    (home-page "https://github.com/Bumblebee-Project/bbswitch")
+    (synopsis "Kernel module that disables discrete Nvidia graphics cards")
+    (description "The bbswitch module provides a way to toggle the Nvidia
+graphics card on Optimus laptops.")
+    (license license:gpl2)))
+
 (define-public ddcci-driver-linux
   (package
     (name "ddcci-driver-linux")