diff mbox series

[bug#41807,06/26] gnu: Add python-trustme.

Message ID 20200611151357.18843-6-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-trustme): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d671c66e9d..f1feccd8c2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20194,3 +20194,29 @@  as tasks, sockets, files, locks, and queues.")
 async function is running under.")
     ;; Choice of either license.
     (license (list license:expat license:asl2.0))))
+
+(define-public python-trustme
+  (package
+    (name "python-trustme")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trustme" version))
+       (sha256
+        (base32
+         "0v3vr5z6apnfmklf07m45kv5kaqvm6hxrkaqywch57bjd2siiywx"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+       ("python-idna" ,python-idna)
+       ("python-ipaddress" ,python-ipaddress)))
+    (home-page
+     "https://github.com/python-trio/trustme")
+    (synopsis
+     "Generates self-signed TLS certificates for testing purposes")
+    (description
+     "@code{python-trustme} is a Python package that generates self-signed
+TLS certificates for testing purposes.")
+    ;; Choice of either license.
+    (license (list license:expat license:asl2.0))))