diff mbox series

[bug#41807,24/26] gnu: Add python-httpx.

Message ID 20200611151357.18843-24-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-web.scm (python-httpx): New variable.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d40dad2e00..daaf4a8934 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4206,3 +4206,31 @@  codebase that is capable of decoding a binary stream into HTTP/2 frames.")
      "@code{python-hstspreload} contains Chromium HSTS Preload list
 as a Python package.")
     (license license:bsd-3)))
+
+(define-public python-httpx
+  (package
+    (name "python-httpx")
+    (version "0.13.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "httpx" version))
+       (sha256
+        (base32
+         "1bpg46mx8n74hxmw2pvgr5pc590hxdsh4wrs4j5bm00bx49vshin"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-certifi" ,python-certifi)
+       ("python-chardet" ,python-chardet)
+       ("python-h11" ,python-h11)
+       ("python-h2" ,python-h2)
+       ("python-hstspreload" ,python-hstspreload)
+       ("python-idna" ,python-idna)
+       ("python-rfc3986" ,python-rfc3986)
+       ("python-sniffio" ,python-sniffio)
+       ("python-urllib3" ,python-urllib3)))
+    (home-page "https://github.com/encode/httpx")
+    (synopsis "HTTP client for Python")
+    (description "HTTPX is a fully featured HTTP client for Python 3,
+which provides sync and async APIs, and support for both HTTP/1.1 and HTTP/2.")
+    (license license:bsd-3)))