diff mbox series

[bug#41807,17/26] gnu: Add python-typing-inspect.

Message ID 20200611151357.18843-17-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-typing-inspect): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c78a6e4be..d6edc33579 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20353,3 +20353,32 @@  to the standard @code{typing} module that are supported by the
      "@{python-flake8-pyi} is a plugin for Flake8 that provides specializations
 for type hinting stub files, especially interesting for linting @code{typeshed}.")
     (license license:expat)))
+
+(define-public python-typing-inspect
+  (package
+    (name "python-typing-inspect")
+    (version "0.6.0")
+    (source
+     (origin
+       ;; There seems to be no source tarball on PyPI.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ilevkivskyi/typing_inspect.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1f612wf0pfwknnrjvnsap08blh706zp0a1lc7gslqyh5vwg7rc5j"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mypy-extensions"
+        ,python-mypy-extensions)
+       ("python-typing-extensions"
+        ,python-typing-extensions)))
+    (home-page
+     "https://github.com/ilevkivskyi/typing_inspect")
+    (synopsis
+     "Runtime inspection utilities for typing module")
+    (description
+     "The @code{typing_inspect} module defines experimental API for
+runtime inspection of types defined in the Python standard typing module.")
+    (license license:expat)))