diff mbox series

[bug#41807,12/26] gnu: Add python-hyperframe.

Message ID 20200611151357.18843-12-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-web.scm (python-hyperframe): New variable.
---
 gnu/packages/python-web.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4810a10834..db53ec8471 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4142,3 +4142,23 @@  own implementation of RFC 6214.")
      "@code{python-hpack} contains a pure-Python HTTP/2 header encoding
 (HPACK) logic for use in Python programs that implement HTTP/2.")
     (license license:expat)))
+
+(define-public python-hyperframe
+  (package
+    (name "python-hyperframe")
+    (version "5.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hyperframe" version))
+       (sha256
+        (base32
+         "07xlf44l1cw0ghxx46sbmkgzil8vqv8kxwy42ywikiy35izw3xd9"))))
+    (build-system python-build-system)
+    (home-page
+     "https://python-hyper.org/hyperframe/en/latest/")
+    (synopsis "HTTP/2 framing layer for Python")
+    (description "@code{python-hyperframe} library contains the HTTP/2
+framing code used in the @code{hyper} project.  It provides a pure-Python
+codebase that is capable of decoding a binary stream into HTTP/2 frames.")
+    (license license:expat)))