diff mbox series

[bug#41807,11/26] gnu: Add python-hpack.

Message ID 20200611151357.18843-11-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-web.scm (python-hpack): New variable.
---
 gnu/packages/python-web.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dcfe523912..4810a10834 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4123,3 +4123,22 @@  IO code whatsoever.  This means you can hook @code{python-h11} up to
 your favorite network API: synchronous, threaded, asynchronous, or your
 own implementation of RFC 6214.")
     (license license:expat)))
+
+(define-public python-hpack
+  (package
+    (name "python-hpack")
+    (version "3.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hpack" version))
+       (sha256
+        (base32
+         "1lp9ja4dk6jg0pm2d18kvh95k9p6yxhh4l1h7y541qzs9cgrrv4f"))))
+    (build-system python-build-system)
+    (home-page "http://hyper.rtfd.org")
+    (synopsis "HTTP/2 Header Encoding for Python")
+    (description
+     "@code{python-hpack} contains a pure-Python HTTP/2 header encoding
+(HPACK) logic for use in Python programs that implement HTTP/2.")
+    (license license:expat)))