diff mbox series

[bug#41807,10/26] gnu: Add python-h11.

Message ID 20200611151357.18843-10-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-web.scm (python-h11): New variable.
---
 gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 83333d5f1c..dcfe523912 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4096,3 +4096,30 @@  based on filters.")
 NodeJS HTTP parser.  It provides collection of framework independent HTTP
 protocol utils.")
     (license license:expat)))
+
+(define-public python-h11
+  (package
+    (name "python-h11")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "h11" version))
+       (sha256
+        (base32
+         "1qfad70h59hya21vrzz8dqyyaiqhac0anl2dx3s3k80gpskvrm1k"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/python-hyper/h11")
+    (synopsis
+     "Python implementation of HTTP/1.1")
+    (description
+     "@code{python-h11} is a little HTTP/1.1 library written from
+scratch in Python, heavily inspired by code{hyper-h2}.
+
+It's a \"bring-your-own-I/O\" library; @code{python-h11} contains no
+IO code whatsoever.  This means you can hook @code{python-h11} up to
+your favorite network API: synchronous, threaded, asynchronous, or your
+own implementation of RFC 6214.")
+    (license license:expat)))