diff mbox series

[bug#41807,01/26] gnu: Add python-outcome.

Message ID 20200611151357.18843-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#41807,01/26] gnu: Add python-outcome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Giacomo Leidi June 11, 2020, 3:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-outcome): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index abf12ec4e0..11630d4818 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20070,3 +20070,31 @@  For the most part it's transliterated from C, the major differences are:
 @end itemize
 ")
     (license license:gpl3+)))
+
+(define-public python-outcome
+  (package
+    (name "python-outcome")
+    (version "1.0.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "outcome" version))
+        (sha256
+          (base32
+            "0vxn04vspmlkkyijjkjnsc46f93ki8g62hr7ag10zpd7ic324y7w"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)))
+    (native-inputs
+     `(("python-async-generator"
+         ,python-async-generator)
+       ("python-pytest" ,python-pytest)))
+    (home-page
+      "https://github.com/python-trio/outcome")
+    (synopsis
+      "Capture the outcome of Python function calls")
+    (description
+     "@code{python-outcome} provides a function for capturing the
+outcome of a Python function call, so that it can be passed around.")
+    ;; Choice of either license.
+    (license (list license:expat license:asl2.0))))