diff mbox series

[bug#41798] gnu: xf86-input-libinput: Reduce closure size.

Message ID 20200611071402.29056-1-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#41798] gnu: xf86-input-libinput: Reduce closure size. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Neidhardt June 11, 2020, 7:14 a.m. UTC
* gnu/packages/xorg.scm (xf86-input-libinput)[inputs]: Replace libinput by
libinput-minimal.
---
 gnu/packages/xorg.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arun Isaac June 11, 2020, 4:06 p.m. UTC | #1
xf86-input-libinput builds fine with this patch and achieves quite a
dramatic closure size reduction from 817 MB to 199 MB! :-)

`guix refresh -l` reports that this change will cause the rebuild of 781
packages. So, according to the manual, this should go to the staging
branch.
Pierre Neidhardt June 11, 2020, 4:28 p.m. UTC | #2
Arun Isaac <arunisaac@systemreboot.net> writes:

> `guix refresh -l` reports that this change will cause the rebuild of 781
> packages. So, according to the manual, this should go to the staging
> branch.

Weird, I get this:

--8<---------------cut here---------------start------------->8---
> guix refresh -l xf86-input-libinput
Building the following 2 packages would ensure 4 dependent packages are rebuilt: lxqt@0.14.1 xfce@4.14.2
--8<---------------cut here---------------end--------------->8---

In fact, to test the patch Guix didn't rebuild anything for me (I don't
use lxqt / xfce).
Arun Isaac June 11, 2020, 6:09 p.m. UTC | #3
Oops, sorry! I accidentally looked up the dependents of
libinput-minimal. Please push to master.

Thanks!
Pierre Neidhardt June 12, 2020, 7:27 a.m. UTC | #4
Thanks!

Pushed with cd0f1fbd1ab1018c022661fa57ddcb91125dd4ab.
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 9a7b856791..e5fe3e14cf 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2556,7 +2556,7 @@  including most mice, keyboards, tablets and touchscreens.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("libinput" ,libinput)
+     `(("libinput" ,libinput-minimal)
        ("xorg-server" ,xorg-server)))
     (home-page "https://www.x.org/wiki/")
     (synopsis "Input driver for X server based on libinput")