diff mbox series

[bug#41756] gnome: gnome-desktop: Add bubblewrap as an input.

Message ID 20200607202226.15637-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#41756] gnome: gnome-desktop: Add bubblewrap as an input. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines June 7, 2020, 8:22 p.m. UTC
This is expected to be available, oddly as libseccomp is available.  These
changes fix thumbnails for Nautilus.

* gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-bubblewrap
phase.
[inputs]: Add bubblewrap.
---
 gnu/packages/gnome.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Ludovic Courtès June 9, 2020, 7:36 a.m. UTC | #1
Hi!

(There’s a typo in the subject prefix.)

Christopher Baines <mail@cbaines.net> skribis:

> This is expected to be available, oddly as libseccomp is available.  These
> changes fix thumbnails for Nautilus.
>
> * gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-bubblewrap
> phase.
> [inputs]: Add bubblewrap.

Nice, I didn’t know the thumbnailer would do that.

> +         (add-before 'configure 'patch-bubblewrap
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (substitute* "libgnome-desktop/gnome-desktop-thumbnail-script.c"
> +               (("\"bwrap\",")
> +                (string-append "\"" (which "bwrap") "\","))
> +               (("\"--ro-bind\", \"/usr\", \"/usr\",")
> +                (string-append "\"--ro-bind\", \""
> +                               (%store-directory)
> +                               "\", \""
> +                               (%store-directory)
> +                               "\","))
> +               (("\"--ro-bind\", \"/etc/ld.so.cache\", \"/etc/ld.so.cache\",")
> +                "\"--ro-bind\", \"/run/current-system\", \"/run/current-system\","))

Perhaps we can replace this second --ro-bind with the empty string?

Otherwise LGTM!

Ludo’.
Christopher Baines June 13, 2020, 11:04 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi!
>
> (There’s a typo in the subject prefix.)
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This is expected to be available, oddly as libseccomp is available.  These
>> changes fix thumbnails for Nautilus.
>>
>> * gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-bubblewrap
>> phase.
>> [inputs]: Add bubblewrap.
>
> Nice, I didn’t know the thumbnailer would do that.
>
>> +         (add-before 'configure 'patch-bubblewrap
>> +           (lambda* (#:key inputs #:allow-other-keys)
>> +             (substitute* "libgnome-desktop/gnome-desktop-thumbnail-script.c"
>> +               (("\"bwrap\",")
>> +                (string-append "\"" (which "bwrap") "\","))
>> +               (("\"--ro-bind\", \"/usr\", \"/usr\",")
>> +                (string-append "\"--ro-bind\", \""
>> +                               (%store-directory)
>> +                               "\", \""
>> +                               (%store-directory)
>> +                               "\","))
>> +               (("\"--ro-bind\", \"/etc/ld.so.cache\", \"/etc/ld.so.cache\",")
>> +                "\"--ro-bind\", \"/run/current-system\", \"/run/current-system\","))
>
> Perhaps we can replace this second --ro-bind with the empty string?
>
> Otherwise LGTM!

Great, I've replaced the second --ro-bind as you suggested, that seems
not to be necessary. I've pushed as
3857aba7ab25c50d64a6d7468d2b5b09bc4f5d60.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 592cab0b49..92411fb698 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1286,6 +1286,20 @@  offline sources, providing a centralized place for managing your contacts.")
                  (("\"locale\"")
                   (string-append "\"" libc "/bin/locale\"")))
                #t)))
+         (add-before 'configure 'patch-bubblewrap
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "libgnome-desktop/gnome-desktop-thumbnail-script.c"
+               (("\"bwrap\",")
+                (string-append "\"" (which "bwrap") "\","))
+               (("\"--ro-bind\", \"/usr\", \"/usr\",")
+                (string-append "\"--ro-bind\", \""
+                               (%store-directory)
+                               "\", \""
+                               (%store-directory)
+                               "\","))
+               (("\"--ro-bind\", \"/etc/ld.so.cache\", \"/etc/ld.so.cache\",")
+                "\"--ro-bind\", \"/run/current-system\", \"/run/current-system\","))
+             #t))
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
              ;; Tests require a running X server and locales.
@@ -1315,6 +1329,7 @@  offline sources, providing a centralized place for managing your contacts.")
     (inputs
      `(("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
+       ("bubblewrap" ,bubblewrap)
        ("libxext" ,libxext)
        ("libxkbfile" ,libxkbfile)
        ("libxrandr" ,libxrandr)))