diff mbox series

[bug#41735,1/2] gnu: Add openssh-no-x.

Message ID 20200606091552.32625-1-othacehe@gnu.org
State Accepted
Headers show
Series Remove X libraries from bare-bones system closure. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Mathieu Othacehe June 6, 2020, 9:15 a.m. UTC
* gnu/packages/ssh.scm (openssh-no-x): New variable.
---
 gnu/packages/ssh.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Janneke Nieuwenhuizen June 6, 2020, 10 a.m. UTC | #1
Mathieu Othacehe writes:

Hello!

> * gnu/packages/ssh.scm (openssh-no-x): New variable.
[..]
> diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
[..]
> +;; OpenSSH without X support. This allows to use OpenSSH without dragging X
> +;; libraries to the closure.
> +(define-public openssh-no-x
> +  (package
> +    (inherit openssh)
> +    (name "openssh-no-x")
> +    (inputs (alist-delete "xauth" (package-inputs openssh)))))

I like it!  Maybe use -sans-x?

Two remarks: after merging, we may want to use openssh-no-x for the Hurd
too and drop this from openssh proper:

             ,@(if (hurd-target?)
                   '()
                   `(("xauth" ,xauth)))))         ; for 'ssh -X' and 'ssh -Y'

We have this bit because xauth does not compile for the Hurd yet,
but it's kind of a kludge.

Not to hold this up and maybe we should take this discussion
elsewhere...but I have a ~5y old, bit-rotting stack of LilyPond cross
build packages (foo-SANS-X) laying around.  At the time--much to my
suprise--I found the LilyPond community less than enthousiastic to move
their binary package builds to Guix (yet); but adding these -NO-X
packages felt a bit weird.  So, I wonder if we could address the X'yness
of packages in a more structured way, that would be nice...

Greetings,
Janneke
Marius Bakke June 6, 2020, 12:40 p.m. UTC | #2
Mathieu Othacehe <m.othacehe@gmail.com> writes:

> * gnu/packages/ssh.scm (openssh-no-x): New variable.
> ---
>  gnu/packages/ssh.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
> index 73841db6b5..13cf305695 100644
> --- a/gnu/packages/ssh.scm
> +++ b/gnu/packages/ssh.scm
> @@ -239,6 +239,14 @@ Additionally, various channel-specific options can be negotiated.")
>                                 "See LICENSE in the distribution."))
>     (home-page "https://www.openssh.com/")))
>  
> +;; OpenSSH without X support. This allows to use OpenSSH without dragging X
> +;; libraries to the closure.
> +(define-public openssh-no-x
> +  (package
> +    (inherit openssh)
> +    (name "openssh-no-x")
> +    (inputs (alist-delete "xauth" (package-inputs openssh)))))

Maybe add a synopsis so users don't have to guess what this package
does.  I.e. (synopsis "OpenSSH client and server without X11 support").

I also think 'openssh-sans-x' is better, and is already a fairly common
convention.  :-)
Mathieu Othacehe June 8, 2020, 9:23 a.m. UTC | #3
Hello Marius,

> Maybe add a synopsis so users don't have to guess what this package
> does.  I.e. (synopsis "OpenSSH client and server without X11 support").
>
> I also think 'openssh-sans-x' is better, and is already a fairly common
> convention.  :-)

Fixed and pushed,

Thanks,

Mathieu
Mathieu Othacehe June 8, 2020, 9:27 a.m. UTC | #4
Hey Jan,

> Two remarks: after merging, we may want to use openssh-no-x for the Hurd
> too and drop this from openssh proper:
>
>              ,@(if (hurd-target?)
>                    '()
>                    `(("xauth" ,xauth)))))         ; for 'ssh -X' and 'ssh -Y'
>
> We have this bit because xauth does not compile for the Hurd yet,
> but it's kind of a kludge.

I just did push the serie, so I think you could maybe adapt the openssh
package used by the Hurd and remove the snippet above, if it's ok for
you?

> Not to hold this up and maybe we should take this discussion
> elsewhere...but I have a ~5y old, bit-rotting stack of LilyPond cross
> build packages (foo-SANS-X) laying around.  At the time--much to my
> suprise--I found the LilyPond community less than enthousiastic to move
> their binary package builds to Guix (yet); but adding these -NO-X
> packages felt a bit weird.  So, I wonder if we could address the X'yness
> of packages in a more structured way, that would be nice...

Yes I share your concerns on that one, sadly I don't have much better to
propose, and I think it's important to have a bare-bones template as
minimal as possible. Anyway, this is not a big hack and it will be easy
to revert it if we find a better way.

Thanks,

Mathieu
Janneke Nieuwenhuizen June 8, 2020, 1:19 p.m. UTC | #5
Mathieu Othacehe writes:

Hi Mathieu,

> I just did push the serie, so I think you could maybe adapt the openssh
> package used by the Hurd and remove the snippet above, if it's ok for
> you?

Yes, sure; I'm right on it.

I just sent my final patch set for wip-hurd-vm, still using plain
"openssh" -- will create an and test updated patch.

>> Not to hold this up and maybe we should take this discussion
>> elsewhere...but I have a ~5y old, bit-rotting stack of LilyPond cross
>> build packages (foo-SANS-X) laying around.  At the time--much to my
>> suprise--I found the LilyPond community less than enthousiastic to move
>> their binary package builds to Guix (yet); but adding these -NO-X
>> packages felt a bit weird.  So, I wonder if we could address the X'yness
>> of packages in a more structured way, that would be nice...
>
> Yes I share your concerns on that one, sadly I don't have much better to
> propose, and I think it's important to have a bare-bones template as
> minimal as possible. Anyway, this is not a big hack and it will be easy
> to revert it if we find a better way.

Okay...I'm sure this will come around another time.

Janneke
diff mbox series

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 73841db6b5..13cf305695 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -239,6 +239,14 @@  Additionally, various channel-specific options can be negotiated.")
                                "See LICENSE in the distribution."))
    (home-page "https://www.openssh.com/")))
 
+;; OpenSSH without X support. This allows to use OpenSSH without dragging X
+;; libraries to the closure.
+(define-public openssh-no-x
+  (package
+    (inherit openssh)
+    (name "openssh-no-x")
+    (inputs (alist-delete "xauth" (package-inputs openssh)))))
+
 (define-public guile-ssh
   (package
     (name "guile-ssh")