diff mbox series

[bug#41639,1/1] gnu: Add vala-language-server.

Message ID 20200603030611.19336-2-rprior@protonmail.com
State Accepted
Headers show
Series Added note to vala-language-server package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

iyzsong--- via Guix-patches via June 3, 2020, 3:06 a.m. UTC
* gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
---
 gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Efraim Flashner June 7, 2020, 3:19 p.m. UTC | #1
Patch 2 and 3 pushed. I'm not convinced (yet!) about renaming vala to
vala-0.46 and making a vala -> vala-0.46 renaming package.

On Wed, Jun 03, 2020 at 03:06:35AM +0000, Ryan Prior via Guix-patches via wrote:
> * gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
> ---
>  gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
> 
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 83e37f97b0..03621b8ccf 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -585,3 +585,36 @@ dark elements.  It supports GNOME, Unity, Xfce, and Openbox.")
>        (description "Papirus is a fork of the icon theme Paper with a lot of new icons
>  and a few extra features.")
>        (license license:gpl3))))
> +
> +(define-public vala-language-server
> +  (package
> +    (name "vala-language-server")
> +    ;; Note to maintainer: VLS must be built with a Vala toolchain the same
> +    ;; version or newer. Therefore when you update this package you may need
> +    ;; to update Vala too.
> +    (version "0.48")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/benwaffle/vala-language-server.git")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
> +    (build-system meson-build-system)
> +    (arguments '(#:glib-or-gtk? #t))
> +    (inputs
> +     `(("jsonrpc-glib" ,jsonrpc-glib)
> +       ("libgee" ,libgee)
> +       ("json-glib" ,json-glib)))
> +    (native-inputs
> +     `(("glib" ,glib)
> +       ("pkg-config" ,pkg-config)
> +       ("vala" ,vala-0.48)))

vala-language-server keeps a reference to glib and vala so I moved them
to inputs.

> +    (home-page "https://github.com/benwaffle/vala-language-server")
> +    (synopsis "Language server for Vala")
> +    (description "The Vala language server is an implementation of the Vala
> +language specification for the Language Server Protocol (LSP).  This tool is
> +used in text editing environments to provide a complete and integrated
> +feature-set for programming Vala effectively.")
> +    (license license:lgpl2.1+)))
> -- 
> 2.26.2
> 
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 83e37f97b0..03621b8ccf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -585,3 +585,36 @@  dark elements.  It supports GNOME, Unity, Xfce, and Openbox.")
       (description "Papirus is a fork of the icon theme Paper with a lot of new icons
 and a few extra features.")
       (license license:gpl3))))
+
+(define-public vala-language-server
+  (package
+    (name "vala-language-server")
+    ;; Note to maintainer: VLS must be built with a Vala toolchain the same
+    ;; version or newer. Therefore when you update this package you may need
+    ;; to update Vala too.
+    (version "0.48")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/benwaffle/vala-language-server.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
+    (build-system meson-build-system)
+    (arguments '(#:glib-or-gtk? #t))
+    (inputs
+     `(("jsonrpc-glib" ,jsonrpc-glib)
+       ("libgee" ,libgee)
+       ("json-glib" ,json-glib)))
+    (native-inputs
+     `(("glib" ,glib)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala-0.48)))
+    (home-page "https://github.com/benwaffle/vala-language-server")
+    (synopsis "Language server for Vala")
+    (description "The Vala language server is an implementation of the Vala
+language specification for the Language Server Protocol (LSP).  This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Vala effectively.")
+    (license license:lgpl2.1+)))