diff mbox series

[bug#41679] gnu: Update protonvpn-cli to 2.2.4

Message ID 20200602234337.11487-1-rprior@protonmail.com
State Accepted
Headers show
Series [bug#41679] gnu: Update protonvpn-cli to 2.2.4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

guix--- via Guix-patches via June 2, 2020, 11:43 p.m. UTC
* gnu/packages/vpn.scm (protonvpn-cli): Update to 2.2.4
---
 gnu/packages/vpn.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Brice Waegeneire June 7, 2020, 9:18 p.m. UTC | #1
Hello Ryan,

Thank you for the patch!

Ryan Prior <rprior@protonmail.com> writes:

> * gnu/packages/vpn.scm (protonvpn-cli): Update to 2.2.4
> ---
>  gnu/packages/vpn.scm | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)

The update is fine, but that package is missing several dependencies, at
least: python-jinja2, coreutils and iproute. Try running it in a pure
environment and it will crash “guix environment --pure --container
--ad-hoc protonvpn-cli -- protonvpn -h”.

Searching the source for “subprocess.run” I find call to other binaries
which aren't listed as dependencies. Could you wrap the “protonvpn”
binary with the “PATH” of all the binaries it uses to avoid propagating
a whole lot of packages. Probably only “python-jinja2” should be
propagated.

- Brice
Ludovic Courtès Sept. 9, 2020, 9:08 p.m. UTC | #2
Hi Ryan,

Ryan Prior <rprior@protonmail.com> skribis:

> * gnu/packages/vpn.scm (protonvpn-cli): Update to 2.2.4

Applied!

Brice Waegeneire <brice@waegenei.re> skribis:

> The update is fine, but that package is missing several dependencies, at
> least: python-jinja2, coreutils and iproute. Try running it in a pure
> environment and it will crash “guix environment --pure --container
> --ad-hoc protonvpn-cli -- protonvpn -h”.
>
> Searching the source for “subprocess.run” I find call to other binaries
> which aren't listed as dependencies. Could you wrap the “protonvpn”
> binary with the “PATH” of all the binaries it uses to avoid propagating
> a whole lot of packages. Probably only “python-jinja2” should be
> propagated.

Alternatively, we can substitute file names (of jinja2, coreutils, and
iproute programs) with absolute file names.

That can be addressed separately, though.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 0f0157806c..cdfddc1e54 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -51,6 +51,7 @@ 
   #:use-module (gnu packages guile)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -316,7 +317,7 @@  traversing network address translators (@dfn{NAT}s) and firewalls.")
 (define-public protonvpn-cli
   (package
     (name "protonvpn-cli")
-    (version "2.2.2")
+    (version "2.2.4")
     (source
      (origin
        ;; PyPI has a ".whl" file but not a proper source release.
@@ -328,7 +329,7 @@  traversing network address translators (@dfn{NAT}s) and firewalls.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0ixjb02kj4z79whm1izd8mrn2h0rp9cmw4im1qvp93rahqxdd4n8"))))
+         "08yca0a0prrnrc7ir7ajd56yxvxpcs4m1k8f5kf273f5whgr7wzw"))))
     (build-system python-build-system)
     (arguments '(#:tests? #f)) ; no tests in repo
     (native-inputs
@@ -337,7 +338,8 @@  traversing network address translators (@dfn{NAT}s) and firewalls.")
      `(("pythondialog" ,python-pythondialog)
        ("requests" ,python-requests)))
     (propagated-inputs
-     `(("openvpn" ,openvpn)))
+     `(("openvpn" ,openvpn)
+       ("dialog" ,dialog)))
     (synopsis "Command-line client for ProtonVPN")
     (description
      "This is the official command-line interface for ProtonVPN, a secure