diff mbox series

[bug#41662] gnu: zsh: Set default '$fpath'.

Message ID 20200602132048.24761-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#41662] gnu: zsh: Set default '$fpath'. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire June 2, 2020, 1:20 p.m. UTC
* gnu/packages/shells.scm (zsh)[arguments]: Add configure-flags
'disable-site-dir' and 'enable-additional-fpath'.
---
 gnu/packages/shells.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès June 11, 2020, 5:08 p.m. UTC | #1
Hi,

Brice Waegeneire <brice@waegenei.re> skribis:

> * gnu/packages/shells.scm (zsh)[arguments]: Add configure-flags
> 'disable-site-dir' and 'enable-additional-fpath'.

[...]

> +                  ,(string-append
> +                    "--enable-additional-fpath="
> +                    "/usr/local/share/zsh/site-functions," ; for foreign OS
> +                    "/run/current-system/profile/share/zsh/site-functions"))

/usr/local seems arbitrary.  What if we omit it, will that break zsh on
foreign distros?

Ludo’.
Brice Waegeneire June 11, 2020, 6:36 p.m. UTC | #2
Hello Ludo',

On 2020-06-11 17:08, Ludovic Courtès wrote:
>> +                  ,(string-append
>> +                    "--enable-additional-fpath="
>> +                    "/usr/local/share/zsh/site-functions," ; for 
>> foreign OS
>> +                    
>> "/run/current-system/profile/share/zsh/site-functions"))
> 
> /usr/local seems arbitrary.  What if we omit it, will that break zsh on
> foreign distros?

I let it there because it's a default[0] and because it was already 
present
in our current zsh package, you can test that with “zsh -df -c 'echo 
$fpath'”.
If I remember correctly I put it there for people using foreign OS who 
still
wants some zsh functions from their host OS.

[0]: https://github.com/zsh-users/zsh/blob/master/NEWS#L415-L424

- Brice
Ludovic Courtès June 12, 2020, 2:46 p.m. UTC | #3
Hi,

Brice Waegeneire <brice@waegenei.re> skribis:

> On 2020-06-11 17:08, Ludovic Courtès wrote:
>>> +                  ,(string-append
>>> +                    "--enable-additional-fpath="
>>> +                    "/usr/local/share/zsh/site-functions," ; for
>>> foreign OS
>>> +
>>> "/run/current-system/profile/share/zsh/site-functions"))
>>
>> /usr/local seems arbitrary.  What if we omit it, will that break zsh on
>> foreign distros?
>
> I let it there because it's a default[0] and because it was already
> present
> in our current zsh package, you can test that with “zsh -df -c 'echo
> $fpath'”.

OK, that makes sense to me.

Thanks,
Ludo’.
Brice Waegeneire June 14, 2020, 1:33 p.m. UTC | #4
Ludovic Courtès <ludo@gnu.org> writes:

> Brice Waegeneire <brice@waegenei.re> skribis:
>
>> On 2020-06-11 17:08, Ludovic Courtès wrote:
>>>> +                  ,(string-append
>>>> +                    "--enable-additional-fpath="
>>>> +                    "/usr/local/share/zsh/site-functions," ; for
>>>> foreign OS
>>>> +
>>>> "/run/current-system/profile/share/zsh/site-functions"))
>>>
>>> /usr/local seems arbitrary.  What if we omit it, will that break zsh on
>>> foreign distros?
>>
>> I let it there because it's a default[0] and because it was already
>> present
>> in our current zsh package, you can test that with “zsh -df -c 'echo
>> $fpath'”.
>
> OK, that makes sense to me.

Pushed as 4f6e6c0442368ac3fd7e95f1fc264671d9182c00.

- Brice
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 74d08e02bc..250c6d5576 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -441,8 +441,16 @@  history mechanism, job control and a C-like syntax.")
                (base32
                 "09yyaadq738zlrnlh1hd3ycj1mv3q5hh4xl1ank70mjnqm6bbi6w"))))
     (build-system gnu-build-system)
-    (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre"
-                                     "--enable-maildir-support")
+    (arguments `(#:configure-flags
+                 `("--with-tcsetpgrp"
+                  "--enable-pcre"
+                  "--enable-maildir-support"
+                  ;; share/zsh/site-functions isn't populated
+                  "--disable-site-fndir"
+                  ,(string-append
+                    "--enable-additional-fpath="
+                    "/usr/local/share/zsh/site-functions," ; for foreign OS
+                    "/run/current-system/profile/share/zsh/site-functions"))
                  #:phases
                  (modify-phases %standard-phases
                    (add-before 'configure 'fix-sh