diff mbox series

[bug#41293,3/3] gnu: Add pantheon-terminal.

Message ID 20200602012736.4292-4-rprior@protonmail.com
State New
Headers show
Series Updated Pantheon packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Deslauriers, Douglas via Guix-patches" via June 2, 2020, 1:28 a.m. UTC
* gnu/packages/pantheon.scm (pantheon-terminal): New variable.
---
 gnu/packages/pantheon.scm | 50 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Marius Bakke June 22, 2020, 7:30 p.m. UTC | #1
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/pantheon.scm (pantheon-terminal): New variable.

[...]

> +    (arguments
> +     `(#:glib-or-gtk? #t
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'install 'set-environment-variables
> +           (lambda _
> +             ;; Disable compiling schemas and updating desktop databases
> +             (setenv "DESTDIR" "/")
> +             #t))

Same comment as patch 1/3.

> +    (synopsis "Graphical terminal with opinionated design and thoughtful touches")

This synopsis borders on "marketing language" (see the section about
Synopses and Descriptions in the manual), but maybe it's OK.

> +    (description "A lightweight, beautiful, and simple terminal application.

Can you turn this into a full sentence?  I.e. "pantheon-terminal is a ...".

> +Comes with sane defaults, browser-like tabs, sudo paste protection, smart
> +copy/paste, and little to no configuration.")

Also here, "It comes with a ...".

> +    (license license:lgpl3)))

Indeed LGPL3 only!  Odd choice.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 6709cd2d8a..250e8e3b2d 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -167,3 +167,53 @@  desktop.")
 on Flathub or another third-party website providing a Flatpak app for
 download.")
     (license license:gpl3)))
+
+(define-public pantheon-terminal
+  (package
+    (name "pantheon-terminal")
+    (version "5.5.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/elementary/terminal.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "119iwmzbpkj4nmxinqfsh73lx23g8gbl6ha6wc4mc4fq9hpnc9c2"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'set-environment-variables
+           (lambda _
+             ;; Disable compiling schemas and updating desktop databases
+             (setenv "DESTDIR" "/")
+             #t))
+         (add-after 'install 'install-symlinks
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin/io.elementary.terminal"))
+                    (link (string-append out "/bin/pantheon-terminal")))
+               (symlink bin link)))))))
+    (inputs
+     `(("granite" ,granite)
+       ("gtk" ,gtk+)
+       ("vte" ,vte)))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib" ,glib)
+       ("appstream" ,appstream)
+       ("libgee" ,libgee)
+       ("desktop-file-utils" ,desktop-file-utils) ; required for tests
+       ("glib:bin" ,glib "bin") ; for glib-compile-resources
+       ("pkg-config" ,pkg-config)
+       ("gobject-introspection" ,gobject-introspection)
+       ("vala" ,vala)))
+    (home-page "https://github.com/elementary/terminal")
+    (synopsis "Graphical terminal with opinionated design and thoughtful touches")
+    (description "A lightweight, beautiful, and simple terminal application.
+Comes with sane defaults, browser-like tabs, sudo paste protection, smart
+copy/paste, and little to no configuration.")
+    (license license:lgpl3)))