diff mbox series

[bug#41644,WIP] gnu: Add aufs-standalone.

Message ID 20200601131903.19100-1-dannym@scratchpost.org
State Accepted
Headers show
Series [bug#41644,WIP] gnu: Add aufs-standalone. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic June 1, 2020, 1:19 p.m. UTC
* gnu/packages/linux.scm (aufs-standalone): New variable.
---
 gnu/packages/linux.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

This package would need a patched Linux kernel (see aufs5-base.patch,
aufs5-mmap.patch and aufs5-standalone.patch)--that's using a definition
of "standalone" I wasn't previously aware of.  So I will not try to
develop this package further for the time being.

Comments

Mathieu Othacehe June 2, 2020, 9:21 a.m. UTC | #1
Hey Danny,

> This package would need a patched Linux kernel (see aufs5-base.patch,
> aufs5-mmap.patch and aufs5-standalone.patch)--that's using a definition
> of "standalone" I wasn't previously aware of.  So I will not try to
> develop this package further for the time being.

Hehe, not that standalone indeed. Maybe we can close this ticket then?

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0a154fd6cc..771fba4593 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -986,6 +986,40 @@  It grants direct and undocumented access to your hardware that may cause damage
 and should be used with caution, especially on untested models.")
       (license license:gpl3+))))        ; see README.md (no licence headers)
 
+(define-public aufs-standalone
+  (let ((commit "230a4e746cb37dc760530233521f732bb932212c") ; branch 5.4
+        (revision "0"))
+    (package
+      (name "aufs-standalone")
+      (version (git-version "5.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/sfjro/aufs5-standalone.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0wq40m8acqqhr2p0sh81wzcdrcabzmvjd15x0y7mdkhwmhyhas9h"))))
+      (build-system linux-module-build-system)
+      (arguments
+       `(#:tests? #f   ; No tests exist
+         #:make-flags
+         (list "CONFIG_AUFS_FS=m"
+               ;; See config.mk
+               "EXTRA_CFLAGS=-DCONFIG_AUFS_BRANCH_MAX_127=y -DCONFIG_AUFS_SBILIST=y -DCONFIG_AUFS_DEBUG=y")
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'chdir
+             (lambda _
+               (chdir "fs/aufs")
+               #t)))))
+      (home-page "https://github.com/sfjro/aufs5-standalone/tree/aufs5.4")
+      (synopsis "Linux kernel module aufs")
+      (description "This package provides the Linux kernel module
+@code{aufs}.")
+      (license license:gpl2+))))
+
 (define-public rtl8812au-aircrack-ng-linux-module
   (let ((commit "945d6ed6505c32f0993b1dba576388e92e78101b")
         (revision "0"))