diff mbox

[bug#37466,WIP,v7,0/4] Add heads and co.

Message ID 20200601130826.5021913a@scratchpost.org
State New
Headers show

Commit Message

Danny Milosavljevic June 1, 2020, 11:08 a.m. UTC
Extra fixes, will be in WIP v8:
diff mbox

Patch

diff --git a/gnu/packages/heads.scm b/gnu/packages/heads.scm
index 1153c6e24d..25940b8f38 100644
--- a/gnu/packages/heads.scm
+++ b/gnu/packages/heads.scm
@@ -625,6 +625,9 @@  servers.")
                (mkdir-p "build")
                (copy-recursively (assoc-ref inputs "linuxboot") "build/linuxboot-git")
                (copy-recursively (assoc-ref inputs "edk2") "build/linuxboot-git/edk2")
+               ;; File is used by Linuxboot (they do an existence check).
+               (call-with-output-file "build/linuxboot-git/edk2/.git"
+                 (const #t))
                (invoke "chmod" "-R" "u+w" "build/linuxboot-git")
                (chmod "build/linuxboot-git/Makefile" #o664)
                (substitute* "build/linuxboot-git/dxe/Makefile"
@@ -641,7 +644,7 @@  servers.")
              (file-name "edk2-checkout")
              (sha256
               (base32 "0crjx1hg1m5mir2qm96dbcc3glrnww3ni0bc9f370qmm337wzlhi"))))
-       ("libuuid" ,util-linux) ; TODO: Move to heads' internal dependencies (for edk2).
+       ("libuuid" ,util-linux "lib") ; TODO: Move to heads' internal dependencies (for edk2).
        ("nasm" ,nasm) ; TODO: Move to heads' internal dependencies (for edk2).
        ("python" ,python-2) ; TODO: Move to heads' internal dependencies (for edk2).
        ("acpica" ,acpica) ; TODO: Move to heads' internal dependencies (for edk2).