@@ -625,6 +625,9 @@ servers.")
(mkdir-p "build")
(copy-recursively (assoc-ref inputs "linuxboot") "build/linuxboot-git")
(copy-recursively (assoc-ref inputs "edk2") "build/linuxboot-git/edk2")
+ ;; File is used by Linuxboot (they do an existence check).
+ (call-with-output-file "build/linuxboot-git/edk2/.git"
+ (const #t))
(invoke "chmod" "-R" "u+w" "build/linuxboot-git")
(chmod "build/linuxboot-git/Makefile" #o664)
(substitute* "build/linuxboot-git/dxe/Makefile"
@@ -641,7 +644,7 @@ servers.")
(file-name "edk2-checkout")
(sha256
(base32 "0crjx1hg1m5mir2qm96dbcc3glrnww3ni0bc9f370qmm337wzlhi"))))
- ("libuuid" ,util-linux) ; TODO: Move to heads' internal dependencies (for edk2).
+ ("libuuid" ,util-linux "lib") ; TODO: Move to heads' internal dependencies (for edk2).
("nasm" ,nasm) ; TODO: Move to heads' internal dependencies (for edk2).
("python" ,python-2) ; TODO: Move to heads' internal dependencies (for edk2).
("acpica" ,acpica) ; TODO: Move to heads' internal dependencies (for edk2).