diff mbox series

[bug#41639,3/3] gnu: Add vala-language-server.

Message ID 20200601055949.1702-3-rprior@protonmail.com
State Accepted
Headers show
Series Adds vala-language-server and updates vala | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

guix--- via Guix-patches via June 1, 2020, 6 a.m. UTC
* gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
---
 gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 83e37f97b0..3c63829e99 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -585,3 +585,33 @@  dark elements.  It supports GNOME, Unity, Xfce, and Openbox.")
       (description "Papirus is a fork of the icon theme Paper with a lot of new icons
 and a few extra features.")
       (license license:gpl3))))
+
+(define-public vala-language-server
+  (package
+    (name "vala-language-server")
+    (version "0.48")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/benwaffle/vala-language-server.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
+    (build-system meson-build-system)
+    (arguments '(#:glib-or-gtk? #t))
+    (inputs
+     `(("jsonrpc-glib" ,jsonrpc-glib)
+       ("libgee" ,libgee)
+       ("json-glib" ,json-glib)))
+    (native-inputs
+     `(("glib" ,glib)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala-0.48)))
+    (home-page "https://github.com/benwaffle/vala-language-server")
+    (synopsis "Language server for Vala")
+    (description "The Vala language server is an implementation of the Vala
+language specification for the Language Server Protocol (LSP).  This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Vala effectively.")
+    (license license:lgpl2.1+)))