diff mbox series

[bug#41610] gnu: glade3: Enable tests.

Message ID 20200529213110.2354-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#41610] gnu: glade3: Enable tests. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Arun Isaac May 29, 2020, 9:31 p.m. UTC
* gnu/packages/gnome.scm (glade3)[arguments]: Enable tests. Add custom
pre-check phase.
[native-inputs]: Add hicolor-icon-theme and xorg-server-for-tests.
---
 gnu/packages/gnome.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

Comments

Mathieu Othacehe June 14, 2020, 10:25 a.m. UTC | #1
Hello Arun,

> -       ("pkg-config" ,pkg-config)))
> +       ("pkg-config" ,pkg-config)
> +       ("xorg-server" ,xorg-server-for-tests)))
>      (home-page "https://glade.gnome.org")
>      (synopsis "GTK+ rapid application development tool")
>      (description "Glade is a rapid application development (RAD) tool to

This looks fine, please go ahead!

Thanks,

Mathieu
Arun Isaac June 15, 2020, 6:40 p.m. UTC | #2
Pushed, thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1745bf7906..02e14233d1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2102,8 +2102,7 @@  API add-ons to make GTK+ widgets OpenGL-capable.")
                 "023gx8rj51njn8fsb6ma5kz1irjpxi4js0n8rwy22inc4ysldd8r"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:tests? #f ; needs X, GL, and software rendering
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'configure 'fix-docbook
            (lambda* (#:key inputs #:allow-other-keys)
@@ -2113,18 +2112,27 @@  API add-ons to make GTK+ widgets OpenGL-capable.")
                                "/xml/xsl/docbook-xsl-"
                                ,(package-version docbook-xsl)
                                "/manpages/docbook.xsl")))
+             #t))
+         (add-before 'check 'pre-check
+           (lambda _
+             (setenv "HOME" "/tmp")
+             ;; Tests require a running X server.
+             (system "Xvfb :1 &")
+             (setenv "DISPLAY" ":1")
              #t)))))
     (inputs
      `(("gtk+" ,gtk+)
        ("libxml2" ,libxml2)))
     (native-inputs
-     `(("intltool" ,intltool)
+     `(("hicolor-icon-theme" ,hicolor-icon-theme)
+       ("intltool" ,intltool)
        ("itstool" ,itstool)
        ("libxslt" ,libxslt) ;for xsltproc
        ("docbook-xml" ,docbook-xml-4.2)
        ("docbook-xsl" ,docbook-xsl)
        ("python" ,python-2)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xorg-server" ,xorg-server-for-tests)))
     (home-page "https://glade.gnome.org")
     (synopsis "GTK+ rapid application development tool")
     (description "Glade is a rapid application development (RAD) tool to