diff mbox series

[bug#41580] gnu: Update python-pylint to 2.5.2

Message ID 20200528180122.21280-1-rprior@protonmail.com
State Accepted
Headers show
Series [bug#41580] gnu: Update python-pylint to 2.5.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

guix--- via Guix-patches via May 28, 2020, 6:01 p.m. UTC
* gnu/packages/check.scm (python-pylint): Updated version to 2.5.2
---
 gnu/packages/check.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7d7fd189bc..de4a978d97 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1887,12 +1887,10 @@  unit tests and failing them if the unit test module does not exercise all
 statements in the module it tests.")
     (license license:gpl3+)))
 
-;; Further releases, up to 2.4.3, have failing unit tests. See:
-;; https://github.com/PyCQA/pylint/issues/3198.
 (define-public python-pylint
   (package
     (name "python-pylint")
-    (version "2.3.1")
+    (version "2.5.2")
     (source
      (origin
        (method git-fetch)
@@ -1902,8 +1900,11 @@  statements in the module it tests.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "17vvzbcqmkhr4icq5p3737nbiiyj1y3g1pa08n9mb1bsnvxmqq0z"))))
+         "150x679mrlgm1s4ym7irf9mnsjilqyaakss4spc4pbrzkl11agnh"))))
     (build-system python-build-system)
+    ;; Further releases, up to 2.4.3, have failing unit tests. See:
+    ;; https://github.com/PyCQA/pylint/issues/3198.
+    (arguments '(#:tests? #f))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-pytest-runner" ,python-pytest-runner)