diff mbox series

[bug#41568] update-guix-package: Use 'origin-hash'.

Message ID 20200527211348.6077-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#41568] update-guix-package: Use 'origin-hash'. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll May 27, 2020, 9:13 p.m. UTC
* gnu/packages/package-management.scm (main): Use 'origin-hash' instead
of 'origin-sha256'.
---
 build-aux/update-guix-package.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

ashish.is--- via Guix-patches" via May 28, 2020, 8:22 a.m. UTC | #1
Vincent,

Strange, it works fine here on 
023eea68f53a6d2979f558fc7590f43aee3aff43:

  ~/guix λ guix environment guix -- make update-guix-package
  git rev-parse HEAD
  aa77b5745dea6591f162c3f2260425479c0da596
  ./pre-inst-env "/gnu/store/…-profile/bin/guile" 
  \
     ./build-aux/update-guix-package.scm	\
     "`git rev-parse HEAD`"
  source code for commit aa77b5745dea6591f162c3f2260425479c0da596:
  /gnu/store/…-guix-1.1.0-5.aa77b57-checkout
  (GC root: guix-1.1.0-5.aa77b57-checkout)
  ~/guix λ

Vincent Legoll 写道:
> * gnu/packages/package-management.scm (main): Use 'origin-hash' 
> instead
> of 'origin-sha256'.

Your change still looks correct so I've pushed it as 
6bfb3eb75dc012e3a0e53da2dc29777c10b6a1ee.

Thanks!

T G-R
Vincent Legoll May 29, 2020, 8:34 a.m. UTC | #2
On 28/05/2020 10:22, Tobias Geerinckx-Rice wrote:
> Vincent,
> 
> Strange, it works fine here on 023eea68f53a6d2979f558fc7590f43aee3aff43:
> 
>   ~/guix λ guix environment guix -- make update-guix-package
>   git rev-parse HEAD
>   aa77b5745dea6591f162c3f2260425479c0da596
>   ./pre-inst-env "/gnu/store/…-profile/bin/guile"  \
>      ./build-aux/update-guix-package.scm    \
>      "`git rev-parse HEAD`"
>   source code for commit aa77b5745dea6591f162c3f2260425479c0da596:
>   /gnu/store/…-guix-1.1.0-5.aa77b57-checkout
>   (GC root: guix-1.1.0-5.aa77b57-checkout)

That's strange indeed, I tried multiple times with various attempts
at fixing it, and got the failure every time.

> Vincent Legoll 写道:
>> * gnu/packages/package-management.scm (main): Use 'origin-hash' instead
>> of 'origin-sha256'.
>
> Your change still looks correct so I've pushed it as 
> 6bfb3eb75dc012e3a0e53da2dc29777c10b6a1ee.

Thanks
diff mbox series

Patch

diff --git a/build-aux/update-guix-package.scm b/build-aux/update-guix-package.scm
index 83f6eca6bb..f695e91cfd 100644
--- a/build-aux/update-guix-package.scm
+++ b/build-aux/update-guix-package.scm
@@ -112,7 +112,8 @@  COMMIT."
                                       #:select? version-controlled?))
               (hash     (query-path-hash store source))
               (location (package-definition-location))
-              (old-hash (origin-sha256 (package-source guix))))
+              (old-hash (content-hash-value
+                          (origin-hash (package-source guix)))))
          (edit-expression location
                           (update-definition commit hash
                                              #:old-hash old-hash