diff mbox series

[bug#41556] gnu: aegis: Update homepage link and fix build failure

Message ID 20200527031226.64428-1-joshua.r.marshall.1991@gmail.com
State Accepted
Headers show
Series [bug#41556] gnu: aegis: Update homepage link and fix build failure | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Anadon May 27, 2020, 3:12 a.m. UTC
* gnu/packages/version-control.scm (aegis): Update homepage link and fix build failure
---
 gnu/packages/version-control.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

guix--- via Guix-patches via May 27, 2020, 11:34 a.m. UTC | #1
Josh,

Josh Marshall 写道:
>     * gnu/packages/version-control.scm (aegis):
  ^^^^

‘git log’ adds 4 leading spaces to commit message bodies but you 
don't need to add (or, I presume, copy/paste :-) them yourself.

> Update homepage link and fix build failure

Thanks!  I've split these two unrelated changes into two commits.

SF project pages aren't goot home pages but this project looks 
very dead indeed.  Are you fixing this because you use it?

> @@ -1885,7 +1885,10 @@ accessed and migrated on modern 
> systems.")
>         ("ed" ,ed)))
>      (arguments
>       `(#:configure-flags (list "--with-no-aegis-configured"
> - 
> "--sharedstatedir=/var/com/aegis")
> + 
> "--sharedstatedir=/var/com/aegis"
> +			       ;; Uses the old 'throw()' specifier 
> with 'new'
> +			       ;; which changed in C++11.
> +			       "CXXFLAGS=-std=c++03")
    ^^^^…

It's worth running ‘guix lint’ even after trivial changes: these 
are tabs & we're a spaces family.  Changed and pushed as 
812dad08764af5ae4d80394732dcc1481742db3a et al.

Kind regards,

T G-R
Anadon May 27, 2020, 12:32 p.m. UTC | #2
Gah!  No matter how many times I tell my editor to use spaces it inserts
tabs.  I'm dumping neovim.

I don't use it, just fixing up something I saw.

On Wed, May 27, 2020, 07:34 Tobias Geerinckx-Rice <me@tobias.gr> wrote:

> Josh,
>
> Josh Marshall 写道:
> >     * gnu/packages/version-control.scm (aegis):
>   ^^^^
>
> ‘git log’ adds 4 leading spaces to commit message bodies but you
> don't need to add (or, I presume, copy/paste :-) them yourself.
>
> > Update homepage link and fix build failure
>
> Thanks!  I've split these two unrelated changes into two commits.
>
> SF project pages aren't goot home pages but this project looks
> very dead indeed.  Are you fixing this because you use it?
>
> > @@ -1885,7 +1885,10 @@ accessed and migrated on modern
> > systems.")
> >         ("ed" ,ed)))
> >      (arguments
> >       `(#:configure-flags (list "--with-no-aegis-configured"
> > -
> > "--sharedstatedir=/var/com/aegis")
> > +
> > "--sharedstatedir=/var/com/aegis"
> > +                            ;; Uses the old 'throw()' specifier
> > with 'new'
> > +                            ;; which changed in C++11.
> > +                            "CXXFLAGS=-std=c++03")
>     ^^^^…
>
> It's worth running ‘guix lint’ even after trivial changes: these
> are tabs & we're a spaces family.  Changed and pushed as
> 812dad08764af5ae4d80394732dcc1481742db3a et al.
>
> Kind regards,
>
> T G-R
>
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 09ffd8f271..deb746db26 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1885,7 +1885,10 @@  accessed and migrated on modern systems.")
        ("ed" ,ed)))
     (arguments
      `(#:configure-flags (list "--with-no-aegis-configured"
-                               "--sharedstatedir=/var/com/aegis")
+                               "--sharedstatedir=/var/com/aegis"
+			       ;; Uses the old 'throw()' specifier with 'new'
+			       ;; which changed in C++11.
+			       "CXXFLAGS=-std=c++03")
        #:parallel-build? #f ; There are some nasty racy rules in the Makefile.
        #:phases
        (modify-phases %standard-phases
@@ -1928,7 +1931,7 @@  accessed and migrated on modern systems.")
 
                ;; The author decided to call the check rule "sure".
                (invoke "make" "sure")))))))
-    (home-page "http://aegis.sourceforge.net")
+    (home-page "https://sourceforge.net/projects/aegis/")
     (synopsis "Project change supervisor")
     (description "Aegis is a project change supervisor, and performs some of
 the Software Configuration Management needed in a CASE environment.  Aegis