diff mbox series

[bug#41550,v3] gnu: Add Polish hunspell dictionary.

Message ID 20200526235019.5971-1-sirmacik@wioo.waw.pl
State Accepted
Headers show
Series [bug#41550,v3] gnu: Add Polish hunspell dictionary. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marcin Karpezo May 26, 2020, 11:50 p.m. UTC
* gnu/packages/libreoffice.scm (hunspell-dict-pl): New variable.
---
Fixing another typo, sorry for that. Will pay more attention next time.

 gnu/packages/libreoffice.scm | 47 ++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

--
2.26.2

Comments

Ludovic Courtès May 29, 2020, 4:07 p.m. UTC | #1
Hello!

Marcin Karpezo <sirmacik@wioo.waw.pl> skribis:

> * gnu/packages/libreoffice.scm (hunspell-dict-pl): New variable.

Looks like the URL is incorrect:

  gnu/packages/libreoffice.scm:929:5: hunspell-dict-pl@20200526: all the source URIs are unreachable:
  gnu/packages/libreoffice.scm:929:5: hunspell-dict-pl@20200526: URI https://sjp.pl/slownik/ort/sjp-myspell-pl-20200526.zip not reachable: 404 ("Not Found")

Could you take a look?

Thanks in advance!

Ludo’.
Marcin Karpezo May 29, 2020, 4:13 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hello!
>
> Marcin Karpezo <sirmacik@wioo.waw.pl> skribis:
>
>> * gnu/packages/libreoffice.scm (hunspell-dict-pl): New variable.
>
> Looks like the URL is incorrect:
>
>   gnu/packages/libreoffice.scm:929:5: hunspell-dict-pl@20200526: all
> the source URIs are unreachable:
>   gnu/packages/libreoffice.scm:929:5: hunspell-dict-pl@20200526: URI
> https://sjp.pl/slownik/ort/sjp-myspell-pl-20200526.zip not reachable:
> 404 ("Not Found")
>
> Could you take a look?

That'd explain why archlinux is mirroring source for each release. Looks
like they're hosting only last release (which happens daily). Do we in
Guix have such capabilities or a way to mitigate that?
Leo Famulari May 29, 2020, 4:53 p.m. UTC | #3
On Fri, May 29, 2020 at 06:13:24PM +0200, sirmacik wrote:
> That'd explain why archlinux is mirroring source for each release. Looks
> like they're hosting only last release (which happens daily). Do we in
> Guix have such capabilities or a way to mitigate that?

We could download it from Arch or another distro that mirrors things.
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a3a6ea5d1a..995ab410ea 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -920,6 +921,52 @@  library.")
   "toutesvariantes"
   (synopsis "Hunspell dictionary for all variants of French"))

+(define-public hunspell-dict-pl
+  (package
+    (name "hunspell-dict-pl")
+    (version "20200526")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://sjp.pl/slownik/ort/sjp-myspell-pl-"
+                           version ".zip"))
+       (sha256 (base32
+                "1v8fc9ka18hs5vl7d515kgd0r4lcxl3pyk5075c5pg8ix9krzs4j"))))
+
+    (build-system trivial-build-system)
+    (native-inputs `(("unzip" ,unzip)))
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils)
+                                (srfi srfi-26))
+
+                   (let* ((out      (assoc-ref %outputs "out"))
+                          (hunspell (string-append out "/share/hunspell"))
+                          (myspell  (string-append out "/share/myspell"))
+                          (doc      (string-append out "/share/doc/"
+                                                   ,name))
+                          (unzip (string-append (assoc-ref %build-inputs "unzip")
+                                                "/bin/unzip")))
+                     (invoke unzip "-j" "-o" (assoc-ref %build-inputs "source"))
+                     (invoke unzip "-j" "-o" "pl_PL.zip")
+                     (for-each (cut install-file <> hunspell)
+                               (find-files "."
+                                           ,(string-append "pl_PL"
+                                                           "\\.(dic|aff)$")))
+                     (mkdir-p myspell)
+                     (symlink hunspell (string-append myspell "/dicts"))
+                     (for-each (cut install-file <> doc)
+                               (find-files "." "\\.(txt|org|md)$"))
+                     #t))))
+    (synopsis "Hunspell dictionary for Polish")
+    (description
+     "This package provides a dictionary for the Hunspell spell-checking
+library.")
+    (home-page "https://sjp.pl/slownik/ort/")
+    (license
+     (list license:gpl2 license:mpl1.1 license:cc-by4.0 license:lgpl2.1 license:asl2.0))))
+
 (define-public hyphen
   (package
     (name "hyphen")