diff mbox series

[bug#41548] gnu: mozjs: Remove static library

Message ID 20200526231557.0e4c40a5@tachikoma.lepiller.eu
State Accepted
Headers show
Series [bug#41548] gnu: mozjs: Remove static library | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Julien Lepiller May 26, 2020, 9:15 p.m. UTC
Hi,

the attached patch removes lib/libjs_static.ajs from the output of
mozjs, a 30 MB static library.  This mozjs is part of the closure of
gdm and gnome, so it reduces the size of most desktop systems.

The reason why I found that file, is because it is mentionned in
BLFS: http://linuxfromscratch.org/blfs/view/svn/general/js68.html

Comments

Leo Famulari May 28, 2020, 5:46 p.m. UTC | #1
On Tue, May 26, 2020 at 11:15:57PM +0200, Julien Lepiller wrote:
> Hi,
> 
> the attached patch removes lib/libjs_static.ajs from the output of
> mozjs, a 30 MB static library.  This mozjs is part of the closure of
> gdm and gnome, so it reduces the size of most desktop systems.

Awesome! I figure that things seem to keep working without it?
Julien Lepiller May 28, 2020, 5:57 p.m. UTC | #2
Le 28 mai 2020 13:46:49 GMT-04:00, Leo Famulari <leo@famulari.name> a écrit :
>On Tue, May 26, 2020 at 11:15:57PM +0200, Julien Lepiller wrote:
>> Hi,
>> 
>> the attached patch removes lib/libjs_static.ajs from the output of
>> mozjs, a 30 MB static library.  This mozjs is part of the closure of
>> gdm and gnome, so it reduces the size of most desktop systems.
>
>Awesome! I figure that things seem to keep working without it?

At least gdm still builds, but I'm not sure how to test it properly
Leo Famulari May 29, 2020, 4:54 p.m. UTC | #3
On Thu, May 28, 2020 at 01:57:32PM -0400, Julien Lepiller wrote:
> Le 28 mai 2020 13:46:49 GMT-04:00, Leo Famulari <leo@famulari.name> a écrit :
> >On Tue, May 26, 2020 at 11:15:57PM +0200, Julien Lepiller wrote:
> >> Hi,
> >> 
> >> the attached patch removes lib/libjs_static.ajs from the output of
> >> mozjs, a 30 MB static library.  This mozjs is part of the closure of
> >> gdm and gnome, so it reduces the size of most desktop systems.
> >
> >Awesome! I figure that things seem to keep working without it?
> 
> At least gdm still builds, but I'm not sure how to test it properly

You could make a vm-image with %desktop-services, which uses GDM.
Julien Lepiller May 30, 2020, 4:07 p.m. UTC | #4
Le Fri, 29 May 2020 12:54:45 -0400,
Leo Famulari <leo@famulari.name> a écrit :

> On Thu, May 28, 2020 at 01:57:32PM -0400, Julien Lepiller wrote:
> > Le 28 mai 2020 13:46:49 GMT-04:00, Leo Famulari <leo@famulari.name>
> > a écrit :  
> > >On Tue, May 26, 2020 at 11:15:57PM +0200, Julien Lepiller wrote:  
> > >> Hi,
> > >> 
> > >> the attached patch removes lib/libjs_static.ajs from the output
> > >> of mozjs, a 30 MB static library.  This mozjs is part of the
> > >> closure of gdm and gnome, so it reduces the size of most desktop
> > >> systems.  
> > >
> > >Awesome! I figure that things seem to keep working without it?  
> > 
> > At least gdm still builds, but I'm not sure how to test it properly
> >  
> 
> You could make a vm-image with %desktop-services, which uses GDM.

Thanks, that's a good idea. I managed to build a vm that way and
unfortunately gdm fails to start, so the static library must be used in
some way. I'm closing this without pushing anything.
Leo Famulari May 30, 2020, 5:08 p.m. UTC | #5
On Sat, May 30, 2020 at 06:07:36PM +0200, Julien Lepiller wrote:
> Thanks, that's a good idea. I managed to build a vm that way and
> unfortunately gdm fails to start, so the static library must be used in
> some way. I'm closing this without pushing anything.

Okay, but did it work without your patch?
diff mbox series

Patch

From 9529f1442323bad4f96fe070a510e1dd64a2c8ce Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Tue, 26 May 2020 23:08:15 +0200
Subject: [PATCH] gnu: mozjs: Remove static library.

* gnu/packages/gnuzilla.scm (mozjs-60): Remove static library.
---
 gnu/packages/gnuzilla.scm | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 7bf9850e97..808c04f1db 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -404,6 +404,12 @@  in C/C++.")
              ;; This test assumes that /bin exists and contains certain
              ;; executables.
              (delete-file "js/src/tests/shell/os.js")
+             #t))
+         (add-after 'install 'remove-static
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; this saves ~30 MB
+             (delete-file (string-append (assoc-ref outputs "out")
+                                         "/lib/libjs_static.ajs"))
              #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
-- 
2.26.2