diff mbox series

[bug#29296,2/2] gexp: Add 'let-system'.

Message ID 20200523004434.059d1960@scratchpost.org
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Danny Milosavljevic May 22, 2020, 10:44 p.m. UTC
Hi Ludo,

maybe a little off-topic, but why do I have to use the following patch on
armhf-linux (*not* cross compiling) in order to stop it from pulling in
i686-cross-gcc?

Makes no sense to me at all...

Comments

Marius Bakke May 22, 2020, 11:01 p.m. UTC | #1
Danny Milosavljevic <dannym@scratchpost.org> writes:

> Hi Ludo,
>
> maybe a little off-topic, but why do I have to use the following patch on
> armhf-linux (*not* cross compiling) in order to stop it from pulling in
> i686-cross-gcc?

Can you give a little more context?  Did this occur after the let-system
patch, or is this when using let-system?

Can you paste the derivation for mes@0.19 in the context this occurs?

Also, please file a new bug report.

> Makes no sense to me at all...

If only all bugs were obvious, our jobs would be so much easier!

> diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
> index 347aef0..524b8e8 100644
> --- a/gnu/packages/mes.scm
> +++ b/gnu/packages/mes.scm
> @@ -120,8 +120,9 @@ extensive examples, including parsers for the Javascript and C99 languages.")
>              ((string-prefix? "x86_64-linux" target-system)
>               ;; Use cross-compiler rather than #:system "i686-linux" to get
>               ;; MesCC 64 bit .go files installed ready for use with Guile.
> -             `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
> -               ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
> +             `( ;("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
> +                ;("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))
> +))
>              (else
>               '())))
>         ("graphviz" ,graphviz)
diff mbox series

Patch

diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 347aef0..524b8e8 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -120,8 +120,9 @@  extensive examples, including parsers for the Javascript and C99 languages.")
             ((string-prefix? "x86_64-linux" target-system)
              ;; Use cross-compiler rather than #:system "i686-linux" to get
              ;; MesCC 64 bit .go files installed ready for use with Guile.
-             `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
-               ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
+             `( ;("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
+                ;("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))
+))
             (else
              '())))
        ("graphviz" ,graphviz)