diff mbox series

[bug#41461,1/3] gnu: Add go-github-com-stretchr-objx.

Message ID 20200522161615.14502-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#41461,1/3] gnu: Add go-github-com-stretchr-objx. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka May 22, 2020, 4:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès June 3, 2020, 3:53 p.m. UTC | #1
Hello,

Jakub Kądziołka <kuba@kadziolka.net> skribis:

> * gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.

[...]

> +    (synopsis "Go package for dealing with maps, slices, JSON and other data")
> +    (description "Go package for dealing with maps, slices, JSON and other data")

Please write a full sentence (or two :-)) for the description (info
"(guix) Synopses and Descriptions").

Otherwise the three patches LGTM!

Ludo’.
Maja Kądziołka June 7, 2020, 7:55 p.m. UTC | #2
On Wed, Jun 03, 2020 at 05:53:49PM +0200, Ludovic Courtès wrote:
> Hello,
> 
> Jakub Kądziołka <kuba@kadziolka.net> skribis:
> 
> > * gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
> 
> [...]
> 
> > +    (synopsis "Go package for dealing with maps, slices, JSON and other data")
> > +    (description "Go package for dealing with maps, slices, JSON and other data")
> 
> Please write a full sentence (or two :-)) for the description (info
> "(guix) Synopses and Descriptions").
> 
> Otherwise the three patches LGTM!

Thanks for your review! I wrote a fuller description and pushed the
patches.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 69f46df743..ccd43cc104 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -917,6 +917,28 @@  increment versions.")
 Go.")
       (license license:expat))))
 
+(define-public go-github-com-stretchr-objx
+  (package
+    (name "go-github-com-stretchr-objx")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stretchr/objx.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/stretchr/objx"))
+    (home-page "https://github.com/stretchr/objx")
+    (synopsis "Go package for dealing with maps, slices, JSON and other data")
+    (description "Go package for dealing with maps, slices, JSON and other data")
+    (license license:expat)))
+
 (define-public go-github-com-stretchr-testify
   (let ((commit
           "b1f989447a57594c728884458a39abf3a73447f7")