diff mbox series

[bug#41452] gnu: sbcl-pass: Update to revision 920f8fc

Message ID 20200522094638.16785-1-sirmacik@wioo.waw.pl
State Accepted
Headers show
Series [bug#41452] gnu: sbcl-pass: Update to revision 920f8fc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marcin Karpezo May 22, 2020, 9:46 a.m. UTC
---
 gnu/packages/wm.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Oleg Pykhalov May 23, 2020, 6:36 a.m. UTC | #1
Hi,

Marcin Karpezo <sirmacik@wioo.waw.pl> writes:

> ---
>  gnu/packages/wm.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 1151b8115d..1d8b6d603e 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1732,7 +1732,7 @@ rendering.")
>        (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
>  
>  (define-public sbcl-stumpwm-pass
> -  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
> +  (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d63")
>          (revision "1"))
>      (package
>        (name "sbcl-pass")

You need to update the sha256, otherwise you will use dd5b0379… if you
have it in a store.  I usually change ony character in sha256 hash, so
Guix will redownload and complain with a right hash.

Also, could you please update other packages with dd5b0379… commit and
send them to 41452@debbugs.gnu.org?
--8<---------------cut here---------------start------------->8---
./gnu/packages/wm.scm
1663-(define-public stumpish
1664:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
--
1703-(define-public sbcl-stumpwm-ttf-fonts
1704:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
--
1734-(define-public sbcl-stumpwm-pass
1735:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
--
1764-(define-public sbcl-stumpwm-globalwindows
1765:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
--
1794-(define-public sbcl-stumpwm-swm-gaps
1795:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")

./gnu/packages/emacs-xyz.scm
15410-(define-public emacs-stumpwm-mode
15411:  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
--8<---------------cut here---------------end--------------->8---

Thanks,
Oleg.
vasilii.smirnov--- via Guix-patches" via May 23, 2020, 12:24 p.m. UTC | #2
Oleg Pykhalov 写道:
>>  (define-public sbcl-stumpwm-pass
>> -  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
>> +  (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d63")
>>          (revision "1"))

Please also increment the revision field for each package when 
applying Oleg's changes.  Update each package in a separate 
commit.

> Update to revision 920f8fc
            ^^^^^^^^
‘Commit’, but even better is to use the full version:

  gnu: sbcl-pass: Update to 0.0.1-2.920f8fc.

Thanks!

T G-R
Marcin Karpezo May 25, 2020, 5:54 p.m. UTC | #3
Hi,

Thanks for additional guidance on how to provide a patch. I've sent them
in 6 parts. Hope they're done right this time.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 1151b8115d..1d8b6d603e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1732,7 +1732,7 @@  rendering.")
       (license (list license:gpl2+ license:gpl3+ license:bsd-2)))))
 
 (define-public sbcl-stumpwm-pass
-  (let ((commit "dd5b037923ec7d3cc27c55806bcec5a1b8cf4e91")
+  (let ((commit "920f8fc1488f7953f205e1dda4c2ecbbbda56d63")
         (revision "1"))
     (package
       (name "sbcl-pass")