diff mbox series

[bug#41392] Upgrade python-argcomplete to 1.11.1

Message ID 20200522063135.GB3278@zpidnp36
State Accepted
Headers show
Series [bug#41392] Upgrade python-argcomplete to 1.11.1 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Lars-Dominik Braun May 22, 2020, 6:31 a.m. UTC
Hi,

> Please use punctuations in commit messages.
> Also mention the removed [inputs].
> Here it should say something along the lines of "...fish31.patch": New file.
> ...(dist_patch_DATA): Add it.
> Finally, can you remove this git patch header, and instead add a short
> free-style comment about what the patch does, and where it comes from
> (URL)?  See other patches for examples.
all done. See attached updated patch.

Cheers,
Lars

Comments

Marius Bakke May 23, 2020, 6:07 p.m. UTC | #1
Lars-Dominik Braun <ldb@leibniz-psychology.org> writes:

> Hi,
>
>> Please use punctuations in commit messages.
>> Also mention the removed [inputs].
>> Here it should say something along the lines of "...fish31.patch": New file.
>> ...(dist_patch_DATA): Add it.
>> Finally, can you remove this git patch header, and instead add a short
>> free-style comment about what the patch does, and where it comes from
>> (URL)?  See other patches for examples.
> all done. See attached updated patch.

Perfect, applied!

I noticed it broke the Python 2 variant, but it only has a single
dependency and is probably not worth fixing.  Let's see if anyone
complains and instead remove it later.  :-)
diff mbox series

Patch

From b02f6b56c0b35e2a47a31516bb9a3a8ad1f82366 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Tue, 19 May 2020 09:24:03 +0200
Subject: [PATCH] gnu: python-argcomplete: Update to 1.11.1.

* gnu/packages/python-xyz.scm (python-argcomplete)[version]: Update to 1.11.1.
[arguments]: Remove, obsolete.
[inputs]: Remove as well.
* gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
 gnu/local.mk                                  |  1 +
 .../python-argcomplete-1.11.1-fish31.patch    | 29 +++++++++++++++++++
 gnu/packages/python-xyz.scm                   | 23 ++-------------
 3 files changed, 33 insertions(+), 20 deletions(-)
 create mode 100644 gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 38b286203e..82497923c8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1409,6 +1409,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-CVE-2018-14647.patch		\
   %D%/packages/patches/python-aiohttp-3.6.2-no-warning-fail.patch	\
   %D%/packages/patches/python-alembic-exceptions-cause.patch	\
+  %D%/packages/patches/python-argcomplete-1.11.1-fish31.patch	\
   %D%/packages/patches/python-axolotl-AES-fix.patch		\
   %D%/packages/patches/python-cairocffi-dlopen-path.patch	\
   %D%/packages/patches/python-cross-compile.patch		\
diff --git a/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch b/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch
new file mode 100644
index 0000000000..98f0ca1473
--- /dev/null
+++ b/gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch
@@ -0,0 +1,29 @@ 
+Upstream commit fixing testcases for fish>=3.1, see
+https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
+
+diff --git a/test/test.py b/test/test.py
+index e91352b..2c34806 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -28,6 +28,8 @@
+ 
+ BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
+ BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
++FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
++FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
+ 
+ 
+ class TempDir(object):
+@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
+     expected_failures = [
+         'test_parse_special_characters',
+         'test_comp_point',
+-        'test_special_characters_double_quoted'
+     ]
++    if FISH_VERSION_TUPLE < (3, 1):
++        expected_failures.extend([
++            'test_special_characters_double_quoted'
++        ])
+ 
+     skipped = [
+         'test_single_quotes_in_single_quotes',
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c26a766d64..bc593120aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13014,33 +13014,16 @@  PNG, JPEG, JPEG2000 and GIF files in pure Python.")
 (define-public python-argcomplete
   (package
     (name "python-argcomplete")
-    (version "1.10.3")
+    (version "1.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "argcomplete" version))
        (sha256
         (base32
-         "02jkc44drb0yjz6x28lvg6rj607n8r2irdpdvyylm8xnycn54zx3"))))
+         "0h1przxffrhqvi46k40pzjsvdrq4zc3sl1pc96kkigqppq0vdrss"))
+       (patches (search-patches "python-argcomplete-1.11.1-fish31.patch"))))
     (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'embed-tool-references
-           (lambda _
-             (substitute* "argcomplete/bash_completion.d/python-argcomplete.sh"
-               ((" grep")
-                (string-append " " (which "grep")))
-               ((" egrep")
-                (string-append " " (which "egrep")))
-               (("elif which")
-                (string-append "elif " (which "which")))
-               (("\\$\\(which")
-                (string-append "$(" (which "which"))))
-             #t)))))
-    (inputs
-     `(("grep" ,grep)
-       ("which" ,which)))
     (native-inputs
      `(("python-coverage" ,python-coverage)
        ("python-flake8" ,python-flake8)
-- 
2.20.1