diff mbox series

[bug#41380] gnu: add glabels

Message ID 20200518211144.64526-1-monego@posteo.net
State Accepted
Headers show
Series [bug#41380] gnu: add glabels | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego May 18, 2020, 9:11 p.m. UTC
---
 gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Nicolas Goaziou May 20, 2020, 6:07 p.m. UTC | #1
Hello,

Vinicius Monego <monego@posteo.net> writes:

> ---
>  gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>

Thank you! Could you use "git format-patch" and provide a commit message
in line with what we usually do for new packages? You may want to check
the commits in the repository to get an idea.

> +(define-public glabels
> +  (package
> +   (name "glabels")
> +   (version "3.4.1")
> +   (source (origin

Nitpick: Could you move "(origin" on the next line?

> +            (method url-fetch)
> +            (uri (string-append "mirror://gnome/sources/" name "/"
> +                                (version-major+minor version)  "/"
> +                                name "-" version ".tar.xz"))

Could you replace "name" with "glabels"? We do not hard-code names
anymore in package definitions.

> +            (sha256
> +             (base32
> +              "0f2rki8i27pkd9r0gz03cdl1g4vnmvp0j49nhxqn275vi8lmgr0q"))))

Nitpick: Could you put the string on the same line as `base32'?

> +   (build-system glib-or-gtk-build-system)
> +   (native-inputs
> +    `(("pkg-config" ,pkg-config)
> +      ("glib:bin" ,glib "bin")
> +      ("gettext" ,gettext-minimal)
> +      ("intltool" ,intltool)
> +      ("itstool" ,itstool)))

Could you re-order alphabetically the native inputs?

> +   (inputs
> +    `(("gtk+" ,gtk+)
> +      ("librsvg" ,librsvg)
> +      ("libxml2" ,libxml2)))
> +   (home-page "http://glabels.org/")

The home-page should be using https

> +   (synopsis "Program for creating labels and business cards.")

Synopsis shouldn't end with a full stop. You may want to lint your
package definition with "guix lint".

> +   (description
> +    "gLabels is a program for creating labels and business cards.  It is
> +designed to work with various laser/ink-jet peel-off label and business
> +card sheets that you’ll find at most office supply stores.")
> +   (license license:gpl3+)))

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5a2032ccf..2f258089be 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10216,3 +10217,34 @@  communicating using the GVariant serialization format instead of JSON when
 both peers support it.  You might want that when communicating on a single
 host to avoid parser overhead and memory-allocator fragmentation.")
     (license license:lgpl2.1+)))
+
+(define-public glabels
+  (package
+   (name "glabels")
+   (version "3.4.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version)  "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "0f2rki8i27pkd9r0gz03cdl1g4vnmvp0j49nhxqn275vi8lmgr0q"))))
+   (build-system glib-or-gtk-build-system)
+   (native-inputs
+    `(("pkg-config" ,pkg-config)
+      ("glib:bin" ,glib "bin")
+      ("gettext" ,gettext-minimal)
+      ("intltool" ,intltool)
+      ("itstool" ,itstool)))
+   (inputs
+    `(("gtk+" ,gtk+)
+      ("librsvg" ,librsvg)
+      ("libxml2" ,libxml2)))
+   (home-page "http://glabels.org/")
+   (synopsis "Program for creating labels and business cards.")
+   (description
+    "gLabels is a program for creating labels and business cards.  It is
+designed to work with various laser/ink-jet peel-off label and business
+card sheets that you’ll find at most office supply stores.")
+   (license license:gpl3+)))