diff mbox series

[bug#41324,v2] gnu: Add dump.

Message ID 20200516135831.27246-1-sirmacik@wioo.waw.pl
State Accepted
Headers show
Series [bug#41324,v2] gnu: Add dump. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marcin Karpezo May 16, 2020, 1:58 p.m. UTC
* gnu/packages/backup.scm (dump): New variable.
---
 gnu/packages/backup.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Marius Bakke May 23, 2020, 7:14 p.m. UTC | #1
Hi Marcin,

Marcin Karpezo <sirmacik@wioo.waw.pl> writes:

> * gnu/packages/backup.scm (dump): New variable.

Thanks!  Can't believe we've gone without this for so long.

[...]
  
> +(define-public dump
> +  (package
> +    (name "dump")
> +    (version "0.4b46")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
> +                           name "/" version "/" name "-" version ".tar.gz"))

Please use "mirror://sourceforge" here.

> +       (sha256
> +        (base32
> +         "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:configure-flags
> +       `("--sysconfdir=/etc"
> +         "--disable-readline"
> +         "--disable-rmt")))
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)
> +       ("autoconf" ,autoconf)
> +       ("zlib" ,zlib)
> +       ("util-linux" ,util-linux "lib")
> +       ("e2fsprogs" ,e2fsprogs)
> +       ("automake" ,automake)))

I ran 'guix size dump' and noticed that the package keeps references to
util-linux, zlib and e2fsprogs.  Probably they should be "inputs"
instead.  Can you confirm and send an updated patch?

Otherwise looks great, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 6a5080bcf8..2157b349dd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1026,6 +1027,44 @@  stored previously can be read back in full at any time.  The program
 is format-agnostic, so you can feed virtually any files to it.")
     (license license:gpl2+)))
 
+(define-public dump
+  (package
+    (name "dump")
+    (version "0.4b46")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
+                           name "/" version "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       `("--sysconfdir=/etc"
+         "--disable-readline"
+         "--disable-rmt")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("zlib" ,zlib)
+       ("util-linux" ,util-linux "lib")
+       ("e2fsprogs" ,e2fsprogs)
+       ("automake" ,automake)))
+    (inputs
+     `(("openssl" ,openssl-1.0)))
+    (home-page "https://dump.sourceforge.io/")
+    (synopsis "Linux Ext2/3/4 filesystem dump/restore utilities")
+    (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium.  Subsequent incremental backups can then be layered on
+top of the full backup.  The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem.  Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+    (license license:bsd-3)))
+
 (define-public burp
   (package
     (name "burp")