diff mbox series

[bug#41323] gnu: Add dump.

Message ID 20200516133800.22780-1-sirmacik@wioo.waw.pl
State Accepted
Headers show
Series [bug#41323] gnu: Add dump. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marcin Karpezo May 16, 2020, 1:38 p.m. UTC
* gnu/packages/backup.scm (dump): New variable.
---
 gnu/packages/backup.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Marcin Karpezo May 16, 2020, 2:01 p.m. UTC | #1
Please close this issue in favour of 41324. I'm sorry for the mess.
Simon Tournier May 16, 2020, 3:56 p.m. UTC | #2
Dear,

On Sat, 16 May 2020 at 16:03, sirmacik <sirmacik@wioo.waw.pl> wrote:
>
> Please close this issue in favour of 41324. I'm sorry for the mess.

To close an issue, you just need to answer to 41323-done@debbugs.gnu.org.

Moreover, if you want to merge 2 bugs, you can send to
control@debbugs.gnu.org containing the body:

      merge 41324 41323


Last, because it seems that 41324 is the v2 of 41323, once you get a
bug number, e.g., 41323, you can send the v2 with:

  git send-email --to=41323@debbugs.gnu.org v2-0001-xxxxxxx.patch


Hope that helps,
simon
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 6a5080bcf8..9655c4a0f6 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1026,6 +1027,45 @@  stored previously can be read back in full at any time.  The program
 is format-agnostic, so you can feed virtually any files to it.")
     (license license:gpl2+)))
 
+(define-public dump
+  (package
+    (name "dump")
+    (version "0.4b46")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
+                           name "/" version "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       `("--sysconfdir=/etc"
+         "--disable-readline"
+         "--disable-uuid"
+         "--disable-rmt")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("autoconf" ,autoconf)
+       ("zlib" ,zlib)
+       ("util-linux" ,util-linux "lib")
+       ("e2fsprogs" ,e2fsprogs)
+       ("automake" ,automake)))
+    (inputs
+     `(("openssl" ,openssl-1.0)))
+    (home-page "https://dump.sourceforge.io/")
+    (synopsis "Linux Ext2/3/4 filesystem dump/restore utilities")
+    (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium.  Subsequent incremental backups can then be layered on
+top of the full backup.  The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem.  Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+    (license license:bsd-3)))
+
 (define-public burp
   (package
     (name "burp")