diff mbox series

[bug#41254] gnu: boost: Add which to native-inputs.

Message ID 20200514101353.27963-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#41254] gnu: boost: Add which to native-inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll May 14, 2020, 10:13 a.m. UTC
To fix:
./bootstrap.sh: line 28: which: command not found

* gnu/packages/boost.scm (boost)[native-inputs]: Add which.
---
 gnu/packages/boost.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

ashish.is--- via Guix-patches" via May 14, 2020, 11:23 a.m. UTC | #1
Vincent,

Thanks for the patch!

Vincent Legoll 写道:
> To fix:
> ./bootstrap.sh: line 28: which: command not found

I'm not convinced that increasing the number of inputs to silence 
(harmless) warnings in the build logs is a way to go.

Is there another reason to add ‘which’?  The resulting boost 
appears identical to one built without it.

Kind regards,

T G-R
Vincent Legoll May 14, 2020, 11:37 a.m. UTC | #2
On 14/05/2020 13:23, Tobias Geerinckx-Rice wrote:
> I'm not convinced that increasing the number of inputs to silence 
> (harmless) warnings in the build logs is a way to go.

It did not look harmless to me...

 >  The resulting boost appears identical to one built without it.

...but it looks like I'm wrong.

> Is there another reason to add ‘which’? 

Nope, feel free to close the issue
ashish.is--- via Guix-patches" via May 14, 2020, 12:13 p.m. UTC | #3
Vincent Legoll 写道:
> On 14/05/2020 13:23, Tobias Geerinckx-Rice wrote:
>> I'm not convinced that increasing the number of inputs to 
>> silence
>> (harmless) warnings in the build logs is a way to go.
>
> It did not look harmless to me...

I understand.  It's actually quite common (as these things go) but 
tends to go unnoticed exactly because it's harmless.  Once you 
notice it you see it everywhere.

> Nope, feel free to close the issue

Done!

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 2f2ca289ab..f6f442c5bf 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -38,6 +38,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages perl)
@@ -82,7 +83,8 @@ 
        ,@(if (%current-target-system)
              '()
              `(("python" ,python-wrapper)))
-       ("tcsh" ,tcsh)))
+       ("tcsh" ,tcsh)
+       ("which" ,which)))
     (arguments
      `(#:imported-modules ((guix build python-build-system)
                            ,@%gnu-build-system-modules)