diff mbox series

[bug#41230] gnu: Add libqglviewer.

Message ID 20200513124407.31539-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#41230] gnu: Add libqglviewer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Kei Kebreau May 13, 2020, 12:44 p.m. UTC
* gnu/packages/qt.scm (libqglviewer): New variable.
---
 gnu/packages/qt.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Ricardo Wurmus May 13, 2020, 7:52 p.m. UTC | #1
Kei Kebreau <kkebreau@posteo.net> writes:

> * gnu/packages/qt.scm (libqglviewer): New variable.

Looks good to me!

> +    (arguments
> +     '(#:tests? #f                      ; no check target
> +       #:make-flags (list (string-append "PREFIX="
> +                                         (assoc-ref %outputs "out")))

Except for the formatting here.  I’d break the line before “(list”.
Kei Kebreau May 13, 2020, 9:05 p.m. UTC | #2
On Wed, 2020-05-13 at 21:52 +0200, Ricardo Wurmus wrote:
> Kei Kebreau <kkebreau@posteo.net> writes:
> 
> > * gnu/packages/qt.scm (libqglviewer): New variable.
> 
> Looks good to me!
> 
> > +    (arguments
> > +     '(#:tests? #f                      ; no check target
> > +       #:make-flags (list (string-append "PREFIX="
> > +                                         (assoc-ref %outputs
> > "out")))
> 
> Except for the formatting here.  I’d break the line before “(list”.
> 

Done and pushed to master as commit e792dd3244.  Thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9d54fde887..caa758d59f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2018 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2698,3 +2699,46 @@  generate Python bindings for your C or C++ code.")
     (description
      "Contains lupdate, rcc and uic tools for PySide2")
     (license license:gpl2)))
+
+(define-public libqglviewer
+  (package
+    (name "libqglviewer")
+    (version "2.7.2")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "http://libqglviewer.com/src/libQGLViewer-"
+                              version ".tar.gz"))
+              (sha256
+               (base32
+                "023w7da1fyn2z69nbkp2rndiv886zahmc5cmira79zswxjfpklp2"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                      ; no check target
+       #:make-flags (list (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke (cons "qmake" make-flags)))))))
+    (native-inputs
+     `(("qtbase" ,qtbase)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("glu" ,glu)))
+    (home-page "http://libqglviewer.com")
+    (synopsis "Qt-based C++ library for the creation of OpenGL 3D viewers")
+    (description
+     "@code{libQGLViewer} is a C++ library based on Qt that eases the creation
+of OpenGL 3D viewers.
+
+It provides some of the typical 3D viewer functionalities, such as the
+possibility to move the camera using the mouse, which lacks in most of the
+other APIs.  Other features include mouse manipulated frames, interpolated
+keyFrames, object selection, stereo display, screenshot saving and much more.
+It can be used by OpenGL beginners as well as to create complex applications,
+being fully customizable and easy to extend.")
+    ;; According to LICENSE, either version 2 or version 3 of the GNU GPL may
+    ;; be used.
+    (license (list license:gpl2 license:gpl3))))