diff mbox series

[bug#41190,2/2] gnu: finance: bitcoin-core: Disable a test that spuriously fails.

Message ID 20200511181656.25849-2-mail@cbaines.net
State Accepted
Headers show
Series Fix bitcoin-core build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Christopher Baines May 11, 2020, 6:16 p.m. UTC
* gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.
---
 gnu/packages/finance.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Marius Bakke May 11, 2020, 8:08 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.

Uff, I pushed a fix for this in 46bbdef24701db8e61326b0645fd426a17111a11
that took the upstream patch.

You are too polite, asking for reviews instead of pushing straight to
master!  :-P

Sorry for the duplicate work.
Christopher Baines May 13, 2020, 6 p.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.
>
> Uff, I pushed a fix for this in 46bbdef24701db8e61326b0645fd426a17111a11
> that took the upstream patch.
>
> You are too polite, asking for reviews instead of pushing straight to
> master!  :-P
>
> Sorry for the duplicate work.

No problem, at least both of us have looked at it, which is sort of like
patch review :)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 094b25c9fe..85023f556c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -155,6 +155,10 @@ 
            (lambda _
              (invoke
               "python3" "./test/functional/test_runner.py"
+              ;; Test fails due to Python deprecation warning in the
+              ;; test. This is fixed upstream
+              ;; https://github.com/bitcoin/bitcoin/pull/17931
+              "--exclude=p2p_invalid_messages"
               (string-append "--jobs=" (number->string (parallel-job-count))))
              #t)))))
     (home-page "https://bitcoin.org/en/")