diff mbox series

[bug#41179] gnu: Add ecm.

Message ID 20200510174450.5540-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#41179] gnu: Add ecm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Kei Kebreau May 10, 2020, 5:44 p.m. UTC
* gnu/packages/compression.scm (ecm): New variable.
---
 gnu/packages/compression.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe May 13, 2020, 9:21 a.m. UTC | #1
Hello,

> +                    (url "https://github.com/alucryd/ecm-tools")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nnb0c"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:tests? #f                      ; no check target
> +       #:make-flags (list "CC=gcc"

Hard-coding CC breaks cross-compilation. See 'powerstat' package for how
to fix it.

> +                          (string-append "DESTDIR=" (assoc-ref %outputs "out")))
> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'configure
> +           (lambda _
> +             (substitute* "Makefile"
> +               (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
> +             #t)))))
> +    (home-page "https://github.com/alucryd/ecm-tools")
> +    (synopsis "Error code modeler")
> +    (description "ECM is a utility that converts ECM files to BIN CD format.")
> +    (license license:gpl3+)))

Maybe you could elaborate a bit on what are ECM files.

Otherwise, seems fine :)

Thanks,

Mathieu
Kei Kebreau May 13, 2020, 1:40 p.m. UTC | #2
On Wed, 2020-05-13 at 11:21 +0200, Mathieu Othacehe wrote:
> Hello,
> 
> > +                    (url "https://github.com/alucryd/ecm-tools")
> > +                    (commit (string-append "v" version))))
> > +              (file-name (git-file-name name version))
> > +              (sha256
> > +               (base32
> > +                "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nn
> > b0c"))))
> > +    (build-system gnu-build-system)
> > +    (arguments
> > +     '(#:tests? #f                      ; no check target
> > +       #:make-flags (list "CC=gcc"
> 
> Hard-coding CC breaks cross-compilation. See 'powerstat' package for
> how
> to fix it.
> 

Thanks for the pointer!  It's been fixed.

> > +                          (string-append "DESTDIR=" (assoc-ref
> > %outputs "out")))
> > +       #:phases
> > +       (modify-phases %standard-phases
> > +         (replace 'configure
> > +           (lambda _
> > +             (substitute* "Makefile"
> > +               (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
> > +             #t)))))
> > +    (home-page "https://github.com/alucryd/ecm-tools")
> > +    (synopsis "Error code modeler")
> > +    (description "ECM is a utility that converts ECM files to BIN
> > CD format.")
> > +    (license license:gpl3+)))
> 
> Maybe you could elaborate a bit on what are ECM files.
> 

Done!

> Otherwise, seems fine :)
> 
> Thanks,
> 
> Mathieu

Thanks for reviewing.  This patch has been pushed to master as commit
3480ceb10a.

Kei
diff mbox series

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index b599f3a603..a71981374e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -12,7 +12,7 @@ 
 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -2189,3 +2189,33 @@  computations.")
     ;; Blosc itself is released under BSD-3 but it incorporates code under
     ;; other non-copyleft licenses.
     (license license:bsd-3)))
+
+(define-public ecm
+  (package
+    (name "ecm")
+    (version "1.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alucryd/ecm-tools")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nnb0c"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f                      ; no check target
+       #:make-flags (list "CC=gcc"
+                          (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "Makefile"
+               (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
+             #t)))))
+    (home-page "https://github.com/alucryd/ecm-tools")
+    (synopsis "Error code modeler")
+    (description "ECM is a utility that converts ECM files to BIN CD format.")
+    (license license:gpl3+)))