diff mbox series

[bug#41175] gnu: tigervnc-server: Update to 1.10.1-1.920d9c4.

Message ID 20200510150310.3184-1-go.wigust@gmail.com
State Accepted
Headers show
Series [bug#41175] gnu: tigervnc-server: Update to 1.10.1-1.920d9c4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Oleg Pykhalov May 10, 2020, 3:03 p.m. UTC
* gnu/packages/vnc.scm (%tigervnc-version, %tigervnc-revision,
%tigervnc-commit): New variables.
(tigervnc-client): Update to 1.10.1-1.920d9c4.
(tigervnc-server)[version]: Update to 1.10.1-1.920d9c4.
[arguments]<#:phases>[patch-xserver]: Fix format procedure call.
[native-inputs]: Use tigervnc-client package source.
---
 gnu/packages/vnc.scm | 45 +++++++++++++++++++++-----------------------
 1 file changed, 21 insertions(+), 24 deletions(-)

Comments

Marius Bakke May 10, 2020, 8:51 p.m. UTC | #1
Oleg Pykhalov <go.wigust@gmail.com> writes:

> * gnu/packages/vnc.scm (%tigervnc-version, %tigervnc-revision,
> %tigervnc-commit): New variables.
> (tigervnc-client): Update to 1.10.1-1.920d9c4.
> (tigervnc-server)[version]: Update to 1.10.1-1.920d9c4.
> [arguments]<#:phases>[patch-xserver]: Fix format procedure call.
> [native-inputs]: Use tigervnc-client package source.

[...]
  
> +(define %tigervnc-version "1.10.1")
> +(define %tigervnc-revision "1")
> +(define %tigervnc-commit "920d9c4d6562ecabf79497bc901d50522d4bc661")

It would be good to leave a comment that this is not actually 1.10.1,
but a snapshot of the 'master' branch.

It would be even better to take the required patches and add it on the
1.10.1 tag.

Otherwise LGTM, thanks!
Oleg Pykhalov May 11, 2020, 9:21 a.m. UTC | #2
First of all thank you for review.


I'm not sure Marius's suggestion about patches is easily applicable,
because it would be a big list of patches and ‘which-patch’ procedure in
‘tigervnc-server’ package should be modified to work with an archive
produced by “origin source” with patches.

Instead I moved ‘%tigervnc-*’ variables to ‘tigervnc-client’ package and
use it as ‘(package-version tigervnc-client)’ in ‘tigervnc-server’.


Also comment about version could be omitted, because as I see we have a
practice to use ‘(commit version)’ in ‘git-reference’ in case we
strictly use release version, and ‘(let ((commit "GIT_HASH")) (package
...))’ in case we use a specific commit.


Pushed to master as d58c9574b3ea91bd796e6072d2ee2ba941abb9c7


Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index 2b5adb899a..aceb62767e 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -42,21 +42,25 @@ 
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xorg))
 
+(define %tigervnc-version "1.10.1")
+(define %tigervnc-revision "1")
+(define %tigervnc-commit "920d9c4d6562ecabf79497bc901d50522d4bc661")
+
 (define-public tigervnc-client
   (package
     (name "tigervnc-client")
-    (version "1.10.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/TigerVNC/tigervnc.git")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "001n189d2f3psn7nxgl8188ml6f7jbk26cxn2835y3mnlk5lmhgr"))))
+    (version (git-version %tigervnc-version %tigervnc-revision
+                          %tigervnc-commit))
+    (source (origin
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/TigerVNC/tigervnc.git")
+                (commit %tigervnc-commit)))
+              (sha256
+               (base32
+                "1lp6mxl5dqlkrzx0q145jzgpbwvhsni3fj6x9ngf8v5s63x82q1p"))
+              (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f ; Tests that do exists are not automated.
@@ -103,17 +107,10 @@  application which is needed to connect to VNC servers.")
   (package
     (inherit xorg-server)
     (name "tigervnc-server")
-    (version "1.10.1")
+    (version (git-version %tigervnc-version %tigervnc-revision
+                          %tigervnc-commit))
     (native-inputs
-     `(("tigervnc-src" ,(origin
-                          (method git-fetch)
-                          (uri
-                           (git-reference
-                            (url "https://github.com/TigerVNC/tigervnc.git")
-                            (commit "v1.9.0")))
-                          (sha256
-                           (base32
-                            "0b47fg3741qs3zdpl2zr0s6jz46dypp2j6gqrappbzm3ywnnmm1x"))))
+     `(("tigervnc-src" ,(package-source tigervnc-client))
        ("autoconf" ,autoconf)
        ("automake" ,automake)
        ("libtool" ,libtool)
@@ -183,9 +180,9 @@  application which is needed to connect to VNC servers.")
                                                           (list-head (string-split xorg-server-version
                                                                                    #\.)
                                                                      2)))
-                                        (fn (format "~a/unix/xserver~a.patch" tvnc-src patch-num)))
+                                        (fn (format #f "~a/unix/xserver~a.patch" tvnc-src patch-num)))
                                      (when (not (file-exists? fn))
-                                       (error (format "Patch file, ~a,
+                                       (error (format #f "Patch file, ~a,
 corresponding to the input xorg-server version, does not exist.  Installation
 will fail.  " fn)))