diff mbox series

[bug#41170] gnu: freecad: Fix build with python-3.8

Message ID 20200510102318.23016-1-boris.dekshteyn@gmail.com
State Accepted
Headers show
Series [bug#41170] gnu: freecad: Fix build with python-3.8 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Boris A. Dekshteyn May 10, 2020, 10:23 a.m. UTC
* gnu/packages/engineering.scm (freecad): Fix build with python-3.8
---
 gnu/packages/engineering.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Marius Bakke May 10, 2020, 9:07 p.m. UTC | #1
"Boris A. Dekshteyn" <boris.dekshteyn@gmail.com> writes:

> * gnu/packages/engineering.scm (freecad): Fix build with python-3.8

Thank you!

[...]

> +       (modules '((guix build utils)))
> +       (snippet
> +        '(begin
> +           ;; https://tracker.freecadweb.org/view.php?id=4143
> +           (substitute* "src/Base/swigpyrun.inl"
> +             (("PyObject \\*modules = interp->modules;")
> +               "PyObject *modules = PyEval_GetBuiltins();")) #t))

I gave a little more context in the comment, moved the #t on a line of
its own, and fixed the indentation.  I also edited the commit message
slightly.

Pushed as 72099cb0f20e87807f29b5a11a584ab7c66297ef.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 15101e3aee..5e204201bd 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2312,6 +2312,13 @@  full programmatic control over your models.")
        (uri (git-reference
              (url "https://github.com/FreeCAD/FreeCAD.git")
              (commit version)))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; https://tracker.freecadweb.org/view.php?id=4143
+           (substitute* "src/Base/swigpyrun.inl"
+             (("PyObject \\*modules = interp->modules;")
+               "PyObject *modules = PyEval_GetBuiltins();")) #t))
        (file-name (git-file-name name version))
        (sha256
         (base32