diff mbox series

[bug#40994] All patches attached

Message ID 20200506054119.5200ef6c.raghavgururajan@disroot.org
State Not Applicable
Headers show
Series [bug#40994] All patches attached | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan May 6, 2020, 9:41 a.m. UTC

diff mbox series

Patch

From 6b4e210a1bc4282f0ff07a6279f55a8f42706a86 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 3 May 2020 00:18:21 -0400
Subject: [PATCH 14/14] gnu: zathura-cb: Update package definition.

* gnu/packages/pwmt.scm (zathura-cb):
[arguments]<#:glib-or-gtk?>: New argument.
[inputs]<cairo,girara,glib,gtk+,json-c,libnotify>: New inputs.
[synopsis]: Updated.
[description]: Updated.
---
 gnu/packages/pwmt.scm | 43 ++++++++++++++++++++++++++-----------------
 1 file changed, 26 insertions(+), 17 deletions(-)

diff --git a/gnu/packages/pwmt.scm b/gnu/packages/pwmt.scm
index 5ad4cbe7f7..f361c91c00 100644
--- a/gnu/packages/pwmt.scm
+++ b/gnu/packages/pwmt.scm
@@ -358,33 +358,42 @@  using the DjVu library.")
   (package
     (name "zathura-cb")
     (version "0.1.8")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
-                              version ".tar.xz"))
-              (sha256
-               (base32
-                "1i6cf0vks501cggwvfsl6qb7mdaf3sszdymphimfvnspw810faj5"))))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (inputs `(("libarchive" ,libarchive)
-              ("zathura" ,zathura)))
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://pwmt.org/projects/zathura-cb/download/"
+                       "zathura-cb-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1i6cf0vks501cggwvfsl6qb7mdaf3sszdymphimfvnspw810faj5"))))
     (build-system meson-build-system)
     (arguments
-     `(#:tests? #f                      ; package does not contain tests
+     `(#:tests? #f                      ; No target
+       #:glib-or-gtk? #t                ; To compile schemas
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.1.8: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
+           ;; This package tries to install into directory of Zathura.
+           ;; That cannot be allowed. Fix it.
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "meson.build"
                (("(install_dir:).*" _ key)
                 (string-append key
                                "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
              #t)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("girara" ,girara)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("json-c" ,json-c)              ; To generate cargs for zathura
+       ("libarchive" ,libarchive)
+       ("libnotify" ,libnotify)        ; To generate cargs for zathura
+       ("zathura" ,zathura)))
+    (synopsis "Comic book support for zathura")
+    (description "The zathura-cb plugin adds comic book support to zathura.")
     (home-page "https://pwmt.org/projects/zathura-cb/")
-    (synopsis "Comic book support for zathura (libarchive backend)")
-    (description "The zathura-cb plugin adds comic book support to zathura
-using libarchive.")
     (license license:zlib)))
-- 
2.26.2